Bug 864988 - gnome-screensaver-command --time does not work and returns an error
gnome-screensaver-command --time does not work and returns an error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
x86_64 Linux
low Severity medium
: beta
: 7.0
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 11:06 EDT by Martin Simon
Modified: 2016-09-19 22:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:07:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-10-10 11:06:59 EDT
Description of problem:
gnome-screensaver-command -t (or --time in long form) does not work and return an error and result 0 seconds.

Version-Release number of selected component (if applicable):
gnome-screensaver-3.6.0-1

How reproducible:
100%

Steps to Reproduce:
1. Execute command "gnome-screensaver-command -l ; sleep 2 ; gnome-screensaver-command -t"
2. 
3.
  
Actual results:
(gnome-screensaver-command:16370): GLib-CRITICAL **: the GVariant format string `(u)' has a type of `(u)' but the given value has a type of `(s)'

(gnome-screensaver-command:16370): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed
The screensaver has been active for 0 seconds.


Expected results:
The screensaver has been active for 2 seconds.

Additional info:
There is another bug that gnome-screensaver-command -a|-d doesn't do anything, maybe the reason is similar.
Comment 1 Matthias Clasen 2012-10-12 19:50:01 EDT
Filed upstream: https://bugzilla.gnome.org/show_bug.cgi?id=686064
Comment 2 Vladimir Benes 2013-01-16 10:55:49 EST
[vbenes@dhcp131-78 ~]$ gnome-screensaver-command -l ; sleep 2 ; gnome-screensaver-command -t
The screensaver has been active for 2 seconds.

-> VERIFIED
Comment 3 Ludek Smid 2014-06-13 07:07:27 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.