Bug 864991 - REST API: VM custom properties are not passed correctly when running VM using Rest API
REST API: VM custom properties are not passed correctly when running VM using...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Ori Liel
Tareq Alayan
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 11:11 EDT by Tareq Alayan
Modified: 2012-12-04 15:01 EST (History)
9 users (show)

See Also:
Fixed In Version: si22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm and engine logs (811.83 KB, application/x-bzip)
2012-10-10 11:11 EDT, Tareq Alayan
no flags Details
params sent with cmCreate (9.99 KB, application/octet-stream)
2012-10-10 11:13 EDT, Tareq Alayan
no flags Details
create vm and start vm XMLs (1.48 KB, application/x-gzip)
2012-10-11 06:37 EDT, Tareq Alayan
no flags Details

  None (edit)
Description Tareq Alayan 2012-10-10 11:11:49 EDT
Created attachment 624954 [details]
vdsm and engine logs

Description of problem:

The fileinject hook test fails when running on si20. This hook
should create a file under '/' called "vdsm_hook_test" and contains
the string "vdsm_hook_test_content" after starting a VM which have
the hook.
When running the test manaually via GUI, the file is uploaded
successfully and everything is OK.
While when running the test manually via the REST API the test fails
i.e. the file is *NOT* created on the vm.

It looks like the custom hook parameters are missing when running vmCreate via REST [see params attachment ] 

How reproducible:
Create a VM with a custom hook fileinject and start through the UI. 
Create a VM using a custom hook fileinject and start the VM via REST API. 
  
Actual results:
UI : works
REST si20: Doesn't work
see attached file 'params'

additional info:
full vdsm.log attached as well
Comment 1 Tareq Alayan 2012-10-10 11:13:35 EDT
Created attachment 624955 [details]
params sent with cmCreate
Comment 2 Tareq Alayan 2012-10-11 06:37:59 EDT
Created attachment 625479 [details]
create vm and start vm XMLs
Comment 3 Ori Liel 2012-10-22 13:00:59 EDT
patch posted upstream: 
   http://gerrit.ovirt.org/#/c/8706/

patch merged upstream: 
   827256a38e8f777a7a2048b6a30844fd22730e3e

patch posted downstream:
   https://gerrit.eng.lab.tlv.redhat.com/#/c/2786/

patch merged downstream: 
   79a26de7337f3d234d4e334a011cd4dbf5266783
Comment 4 Tareq Alayan 2012-10-31 10:34:40 EDT
Bug found and verified
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Core+Tools/job/3.1-automation_hosts/

Note You need to log in before you can comment on or make changes to this bug.