Bug 864998 - fail2ban improperly logging to syslog as kern.emerg
fail2ban improperly logging to syslog as kern.emerg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fail2ban (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 845802
  Show dependency treegraph
 
Reported: 2012-10-10 11:16 EDT by Matthew Miller
Modified: 2012-12-17 17:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845802
Environment:
Last Closed: 2012-12-17 17:23:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-10 11:16:22 EDT
+++ This bug was initially created as a clone of Bug #845802 +++

Description of problem:

We have fail2ban configured with loglevel = 3, logtarget = SYSLOG; but fail2ban is logging to syslog with kern.emerg priority.

kern.emerg<0>: Aug  1 18:08:44 gate1 ?<28>fail2ban.actions: WARNING [ssh-iptables] Unban 10.228.1.11

Effectively, this means that such messages are logged to all user consoles, due to the default rsyslog config on RHEL6.

*.emerg  *


Version-Release number of selected component (if applicable):

RHEL6.3, fail2ban-0.8.4-28.el6.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Install fail2ban and configure for ssh banning
2. Invoke a ban (or wait for an unban)
  
Actual results:

Message is logged to syslog as an emergency.

Expected results:

Message is logged as info (loglevel 3).

--- Additional comment from redhat-bugzilla@very.puzzling.org on 2012-08-15 00:29:23 EDT ---

This appears to have been fixed in fail2ban 0.8.7:

https://github.com/fail2ban/fail2ban/issues/32

--- Additional comment from jonathon.anderson@kaust.edu.sa on 2012-08-28 04:33:06 EDT ---

> This appears to have been fixed in fail2ban 0.8.7 

It looks like the latest in EPEL is 0.8.4(-28).  What needs to happen to get this fix backported, or get fail2ban upgraded?

--- Additional comment from admiller@redhat.com on 2012-10-05 11:29:06 EDT ---

I don't maintain this package for "Fedora proper", only EPEL and I would like not to have EPEL be ahead of Fedora, please file a request for the Fedora package to be updated and I will happily follow suit.
Comment 1 Jonathon Anderson 2012-10-13 02:21:15 EDT
> please file a request for the Fedora package

It looks like you've done this at 864998.  Thank-you for following-up.
Comment 2 Jonathon Anderson 2012-10-13 02:22:58 EDT
> It looks like you've done this at 864998.

And now I see I've replied to the wrong bug, with the wrong bug id.

Oh, well.  You guys are doing great.  Thanks.
Comment 3 Orion Poplawski 2012-12-17 17:23:18 EST
This is a python issue and is fine in Fedora.

Note You need to log in before you can comment on or make changes to this bug.