Bug 865000 - [BUG] disabling of all repos but beaker ones can cause dependency issues
[BUG] disabling of all repos but beaker ones can cause dependency issues
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.10.0
: ---
Assigned To: Dan Callaghan
Qixiang Wan
Misc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 11:19 EDT by Bill Peck
Modified: 2012-11-22 01:44 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 01:44:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-10-10 11:19:10 EDT
Description of problem:
Fedora17 installs with updates enabled, but after install beah installs tasks with all repos but beaker ones disabled.  This causes problems for any packages that were installed from the updates repo since any sub-packages that may be required by tests can't be installed.

I suggest we remove the --disablerepo=* --enablerepo=beaker-* from the beah task installer.

Version-Release number of selected component (if applicable):
0.9.3

Additional info:

Example Error messages from this bug:

Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package tmp-CoreOS-sssd-RHEL6.4-389DSSetup.noarch 0:1.2-0 will be installed
--> Processing Dependency: openldap-clients for package: tmp-CoreOS-sssd-RHEL6.4-389DSSetup-1.2-0.noarch
--> Running transaction check
---> Package openldap-clients.x86_64 0:2.4.30-2.fc17 will be installed
--> Processing Dependency: openldap(x86-64) = 2.4.30-2.fc17 for package: openldap-clients-2.4.30-2.fc17.x86_64
--> Finished Dependency Resolution
Error: Package: openldap-clients-2.4.30-2.fc17.x86_64 (beaker-Fedora)
           Requires: openldap(x86-64) = 2.4.30-2.fc17
           Installed: openldap-2.4.32-3.fc17.x86_64 (@myupdates)
               openldap(x86-64) = 2.4.32-3.fc17
           Available: openldap-2.4.30-2.fc17.x86_64 (beaker-Fedora)
               openldap(x86-64) = 2.4.30-2.fc17

 You could try using --skip-broken to work around the problem
Comment 1 Dan Callaghan 2012-10-24 02:15:06 EDT
On Gerrit: http://gerrit.beaker-project.org/1435
Comment 3 Qixiang Wan 2012-11-09 01:28:44 EST
Verified with new build. The '--disablerepo=* --enablerepo=beaker-*' has been removed from yum command line and didn't cause any issue with task rpm installation.

[root@guest3 ~]# grep '_install_test()' -A3 /mnt/testarea/tmpQsKCDA.sh 
_install_test() {
    beahsh extend_watchdog 20m
    yum -y install "$TESTRPMNAME"
}
Comment 4 Raymond Mancy 2012-11-22 01:44:24 EST
This has now been released

Note You need to log in before you can comment on or make changes to this bug.