This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865013 - iasl endianness problem when compiling seabios
iasl endianness problem when compiling seabios
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iasl (Show other bugs)
18
ppc Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
Depends On: 856856
Blocks: F18Betappc
  Show dependency treegraph
 
Reported: 2012-10-10 11:46 EDT by Richard W.M. Jones
Modified: 2012-11-28 12:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 856856
Environment:
Last Closed: 2012-11-28 12:23:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix endianness issues on iasl v20100528 (95.05 KB, patch)
2012-10-17 03:21 EDT, Paolo Bonzini
no flags Details | Diff
rawhide version of the patch (97.63 KB, patch)
2012-10-17 03:45 EDT, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2012-10-10 11:46:09 EDT
Compiling IASL out/acpi-dsdt.hex
ASL Input:  out/acpi-dsdt.dsl.i - 629 lines, 22960 bytes, 344 keywords
AML Output: out/acpi-dsdt.aml - 4682 bytes, 163 named objects, 181 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 257 Optimizations
  Compiling IASL out/ssdt-proc.hex
ASL Input:  out/ssdt-proc.dsl.i - 36 lines, 765 bytes, 8 keywords
AML Output: out/ssdt-proc.aml - 120 bytes, 6 named objects, 2 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 0 Optimizations
Error: Name offset 0x24: expected 0x5B 0x83 actual 0x83 0x5b; input line 22: /* ACPI_EXTRACT_PROCESSOR_START ssdt_proc_start */
make: *** [out/ssdt-proc.hex] Error 1

Note: 0x5B 0x83 vs 0x83 0x5b.  Go Intel.
Comment 1 Paolo Bonzini 2012-10-17 03:21:25 EDT
Created attachment 628571 [details]
patch to fix endianness issues on iasl v20100528

It turns out that Debian has patches to fix this issue.
Comment 2 Paolo Bonzini 2012-10-17 03:45:42 EDT
Created attachment 628586 [details]
rawhide version of the patch

The new version was imported in rawhide just last week by Richard, presumably in an attempt to fix this problem, and IMO can be reverted to the older one on which Debian's patches are based.
Comment 3 Fedora Update System 2012-10-17 06:25:02 EDT
iasl-20100528-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iasl-20100528-6.fc18
Comment 4 Fedora Update System 2012-10-17 13:32:51 EDT
Package iasl-20100528-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iasl-20100528-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16299/iasl-20100528-6.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.