Bug 86505 - xdm does not run Xwilling
xdm does not run Xwilling
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
8.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2003-03-24 15:24 EST by F J H
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 14:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description F J H 2003-03-24 15:24:15 EST
Description of problem:
It seems that it is not possible to su to "nobody"
as its shell is set to nologin in /etc/passwd.  Thus the resource
DisplayManager.willing:         su nobody -c /etc/X11/xdm/Xwilling
in /etc/X11/xdm/xdm-config does not produce the intended result.
If you try to run that command as root you'll see Xwilling does not run.
Changing the -c to -s works, though maybe it shouldn't since the arg
is not a valid shell.  Adding "-s /bin/sh" may be more correct.


Version-Release number of selected component (if applicable):
3.31-1


How reproducible: always


Steps to Reproduce:
1. install minimal redhat 8.0
2. add in XFree86-xdm and its prerequisites then enable XDMCP
3. point an X terminal at it
    
Actual results:
Chooser shows "This account is currently not available."


Expected results:
Chooser shows "1 user, load: 0.00, 0.00, 0.00" (for example).


Additional info:
Comment 1 Mike A. Harris 2004-09-29 16:00:49 EDT
This issue seems to be present in both the XFree86 and X.Org code bases.
We encourage you to upgrade to the latest version of Fedora Core
(http://fedora.redhat.com) to verify that the bug still exists.
If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.
Comment 2 Mike A. Harris 2005-04-05 14:49:27 EDT
Fixed in xinitrc-4.0.17-1 in rawhide, buy changing -c to -s /bin/bash
Comment 3 Mike A. Harris 2006-01-09 11:49:44 EST
(In reply to comment #2)
> Fixed in xinitrc-4.0.17-1 in rawhide, buy changing -c to -s /bin/bash
> 

Nice English on me there...   s/buy/by/
Must have been tired that day...

Note You need to log in before you can comment on or make changes to this bug.