Bug 865066 - 'Software selection' spoke is incorrectly rendered on top of the hub if you enter the 'software selection' spoke while 'installation source' is a remote mirror
'Software selection' spoke is incorrectly rendered on top of the hub if you e...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Dan Mashal
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-10 14:16 EDT by Adam Williamson
Modified: 2012-10-23 09:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 09:05:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the bug (163.08 KB, image/png)
2012-10-10 14:16 EDT, Adam Williamson
no flags Details
screenshot (126.56 KB, image/png)
2012-10-11 01:50 EDT, Dan Mashal
no flags Details

  None (edit)
Description Adam Williamson 2012-10-10 14:16:34 EDT
Created attachment 625082 [details]
screenshot of the bug

To reproduce this, do the following:

Boot F18 Beta TC3 DVD
Click 'Installation source' and change it to 'Closest mirror' (on the network)
Click 'Done'
Click 'Software Selection' (note it acquires a warning triangle after the 'installation source' change, requiring you to click on it)

The 'Software Selection' spoke is rendered badly - it appears to just get dumped at an offset on top of the hub screen. See attached screenshot. This appears to be 100% reproducible. The spoke still _works_ so this isn't a showstopper, but it looks bad.
Comment 1 Chris Lumens 2012-10-10 14:30:03 EDT
http://clumens.fedorapeople.org/865066.img is an updates image build with everything since anaconda-18.14-1 which is a little broad.  This also includes a one-liner for the widgets that I'm hoping takes care of this.
Comment 2 Adam Williamson 2012-10-10 20:15:07 EDT
Nope, sorry, doesn't fix it. No change. I checked the update image is downloaded and applied, it's there in /tmp/updates , but behaviour is precisely as described above.
Comment 3 Chris Lumens 2012-10-10 20:46:57 EDT
Bah.
Comment 4 Dan Mashal 2012-10-11 01:50:40 EDT
Created attachment 625336 [details]
screenshot
Comment 5 Dan Mashal 2012-10-11 01:51:51 EDT
Reproduced on smoke 7 netinst, screenshot attached. Seems to have started happening when you guys made GNOME Desktop selected by default. ;)
Comment 6 Chris Lumens 2012-10-11 11:26:06 EDT
Adam - do you have any idea when you first started seeing this?  It'd be helpful to know what things changed so I can know where to even begin here.  Because right now, I don't have much of a clue.
Comment 7 Adam Williamson 2012-10-11 12:11:31 EDT
Chris: not right now, but I can test back easy enough.

Chris Murphy points out that this blocks access to the Minimal package set, which is required in the criteria, so this is unfortunately a blocker, proposing.

Dan Mashal says all you have to do to reproduce this is boot netinst.iso and hit the Software Selection spoke, so I think the reproducer is actually as simple as 'go into Software Selection with the Installation Source set to a remote mirror'.
Comment 8 Adam Williamson 2012-10-11 12:39:05 EDT
So I've confirmed that to reproduce this all you need to do is boot a netinst ISO and go into the 'Software Selection' spoke. I can also confirm it goes all the way back to Beta TC1.
Comment 9 Adam Williamson 2012-10-11 12:46:02 EDT
Crazy idea: perhaps this bug involves the content of the remote mirror somehow? That might explain why more people didn't notice it before, but it now seems to be happening even with TC1 and TC2?
Comment 10 Adam Williamson 2012-10-11 12:46:36 EDT
Discussed at 2012-10-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-11/f18beta-blocker-review-3.1.2012-10-11-16.04.log.txt . Accepted as a blocker per Alpha criterion "The installer must be able to install each of the release blocking desktops, as well as the minimal package set, with each supported installation method" - as noted above, this bug stops you seeing the minimal package set.
Comment 11 Chris Murphy 2012-10-11 13:27:51 EDT
(In reply to comment #6)
> Adam - do you have any idea when you first started seeing this?

It was not happening with Fedora-18-Beta-TC2-x86_64-netinst.iso or before.

It is definitely happening today with Fedora-18-Beta-TC3-x86_64-netinst.iso

And I just tried it with betaTC1 and it is happening. So it's definitely related to package metadata IMO. I'm pretty sure it started within the last 36 hours.
Comment 12 Chris Lumens 2012-10-11 14:34:09 EDT
Yeah, got it.

Note:  The Cinnamon environment's description is ".".  That'll need to be changed in comps.
Comment 13 Adam Williamson 2012-10-11 14:59:59 EDT
For the record, we worked out that the problem here is when there's more environments in the list than will fit in the Environment box (the left-hand one) without scrolling. So the reason this bug suddenly started showing up even in old composes, but we hadn't seen it before, is that Cinnamon and MATE were recently added to comps, which gives us more desktops than will fit in the box at some resolutions.
Comment 14 Fedora Update System 2012-10-11 21:06:08 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 15 Fedora Update System 2012-10-12 13:55:34 EDT
Package anaconda-18.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16018/anaconda-18.16-1.fc18
then log in and leave karma (feedback).
Comment 16 Kamil Páral 2012-10-15 10:01:04 EDT
This is fixed in F18 Beta TC4.
Comment 17 Chris Murphy 2012-10-15 13:14:46 EDT
Fixed for me as well.
Comment 18 Fedora Update System 2012-10-16 23:09:08 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 19 Fedora Update System 2012-10-17 13:30:52 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 20 Adam Williamson 2012-10-17 20:10:21 EDT
Back to VERIFIED.
Comment 21 Fedora Update System 2012-10-17 22:38:02 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 22 Fedora Update System 2012-10-18 11:30:27 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2012-10-19 21:33:48 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 24 Fedora Update System 2012-10-19 23:52:00 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 25 Kamil Páral 2012-10-23 09:05:16 EDT
Fixed, anaconda stable, closing.

Note You need to log in before you can comment on or make changes to this bug.