This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865098 - Backend: incomplete error message in engine.log: "Failed to query rootDSE for LDAP server LDAP://qa2-tlv.qa.lab.tlv.redhat.com:389 due to qa2-tlv.qa.lab.tlv.redhat.com:389"
Backend: incomplete error message in engine.log: "Failed to query rootDSE for...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Yair Zaslavsky
Tareq Alayan
infra
: ZStream
Depends On:
Blocks: 879721 915537
  Show dependency treegraph
 
Reported: 2012-10-10 15:55 EDT by Yaniv Kaul
Modified: 2016-02-10 14:03 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879721 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-10-10 15:55:40 EDT
Description of problem:
When failing to contact the AD domain controller, the following event can be seen in the engine.log, which is missing the real cause:

"Failed to query rootDSE for LDAP server LDAP://qa2-tlv.qa.lab.tlv.redhat.com:389 due to qa2-tlv.qa.lab.tlv.redhat.com:389"

Part of the code relevant to this is probably

} catch (NamingException e) {
            log.errorFormat("Failed to query rootDSE for LDAP server {0} due to {1}", ldapURI, e.getMessage());

(from upstream's backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/GetRootDSE.java)

Version-Release number of selected component (if applicable):
SI20

How reproducible:


Steps to Reproduce:
1. Make sure the first AD domain controller you try to connect to does not respond, and try to login with a user from the AD domain to the system.
2.
3.
  
Actual results:


Expected results:


Additional info:
2012-10-10 09:30:37,888 INFO  [org.ovirt.engine.core.bll.adbroker.GetRootDSE] (ajp-/127.0.0.1:8702-3) Trying to auto-detect the LDAP provider type for domain qa.lab.tlv.redhat.com
2012-10-10 09:30:37,894 ERROR [org.ovirt.engine.core.bll.adbroker.DirectorySearcher] (ajp-/127.0.0.1:8702-2) Failed ldap search server LDAP://qa2-tlv.qa.lab.tlv.redhat.com:389 due to javax.naming.CommunicationException: qa2-tlv.qa.lab.tlv.redhat.com:389 [Root exception is java.net.SocketTimeoutException: connect timed out]. We should try the next server
2012-10-10 09:31:07,921 ERROR [org.ovirt.engine.core.bll.adbroker.GetRootDSE] (ajp-/127.0.0.1:8702-3) Failed to query rootDSE for LDAP server LDAP://qa2-tlv.qa.lab.tlv.redhat.com:389 due to qa2-tlv.qa.lab.tlv.redhat.com:389
Comment 3 Tareq Alayan 2013-05-22 07:52:09 EDT
2013-05-22 14:43:26,250 ERROR [org.ovirt.engine.core.bll.adbroker.GetRootDSE] (ajp-/127.0.0.1:8702-2) Failed to query rootDSE for LDAP server ldap://fake.qa.lab.tlv.redhat.com:389 due to fake.qa.lab.tlv.redhat.com:389
2013-05-22 14:43:26,253 ERROR [org.ovirt.engine.core.bll.adbroker.DirectorySearcher] (ajp-/127.0.0.1:8702-2) Failed ldap search server ldap://fake.qa.lab.tlv.redhat.com:389 using user hhhh@QA.LAB.TLV.REDHAT.COM due to javax.naming.CommunicationException: fake.qa.lab.tlv.redhat.com:389 [Root exception is java.net.UnknownHostException: fake.qa.lab.tlv.redhat.com]. We should try the next server
2013-05-22 14:43:26,254 ERROR [org.ovirt.engine.core.bll.adbroker.LdapBrokerCommandBase] (ajp-/127.0.0.1:8702-2) Failed to run command LdapAuthenticateUserCommand. Domain is qa.lab.tlv.redhat.com. User is hhhh.}
Comment 4 Itamar Heim 2013-06-11 04:35:35 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 04:35:39 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:35:51 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:44:23 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.