Bug 865110 - UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 270: invalid continuation byte
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 270: inva...
Status: CLOSED WONTFIX
Product: Pulp
Classification: Community
Component: API/integration (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Connor
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 16:32 EDT by Jason Connor
Modified: 2014-03-30 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 12:08:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 835586 None None None 2012-10-10 16:32:58 EDT

  None (edit)
Description Jason Connor 2012-10-10 16:32:58 EDT
Description of problem:

Synchronization of RHEL content for an Organization with an i18n name fails (seems to be at the end of the process) with the following error:

UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 270: invalid continuation byte

Version-Release number of selected component (if applicable):

* candlepin-0.6.5-1.el6_2.noarch
* candlepin-tomcat6-0.6.5-1.el6_2.noarch
* katello-0.1.318-1.el6cf.noarch
* katello-all-0.1.318-1.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.7-1.el6_3.noarch
* katello-cli-0.1.112-1.el6cf.noarch
* katello-cli-common-0.1.112-1.el6cf.noarch
* katello-common-0.1.318-1.el6cf.noarch
* katello-configure-0.1.110-1.el6_3.noarch
* katello-glue-candlepin-0.1.318-1.el6cf.noarch
* katello-glue-foreman-0.1.318-1.el6cf.noarch
* katello-glue-pulp-0.1.318-1.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.10-1.el6.noarch
* pulp-1.0.4-1.el6.noarch
* pulp-common-1.0.4-1.el6.noarch
* pulp-selinux-server-1.0.4-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. Create user Mané with the Administrator role. Log in as this user.
2. Create organization: Cuiabá
3. Add the following environments: Library -> Desenvolvimento -> ControleQualidade
4. Upload a valid manifest file and enable the following repositories: RHEL 6Server RPMS, CF Tools and SAM (all x86_64)
5. Synchronize all of the enabled repositories
  
Actual results:

The sync process eventually breaks and the error already mentioned is found in pulp.log

Expected results:

Sync should be completed

Additional info:

Note You need to log in before you can comment on or make changes to this bug.