Bug 865162 - kexec-tools update needed
kexec-tools update needed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 18:00 EDT by joshua
Modified: 2013-02-25 04:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 04:15:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-10-10 18:00:02 EDT
Description of problem:

I'm looking for this patch in kexec:

commit 0e4946bc3009e7b9ce6f9d792077eddd7e40cc14
Author: Eric Biggers <ebiggers3@gmail.com>
Date:   Tue Jun 5 19:46:07 2012 -0400

    Load bzImages smaller than 32 KiB
    
    Allow bzImages smaller than 32KiB to be kexec'ed.

See http://git.kernel.org/?p=utils/kernel/kexec/kexec-tools.git;a=commit;h=0e4946bc3009e7b9ce6f9d792077eddd7e40cc14 for more info.


Can we get an updated kexec-tools with this patch?



Version-Release number of selected component (if applicable):

F17
Comment 1 joshua 2012-10-12 00:28:09 EDT
F17 and F18 please!
Comment 2 Dave Young 2012-10-12 00:39:29 EDT
Hi, I'm occupied by some other things, I can build a test rpm for you, can you help to test it?
Comment 3 joshua 2012-10-12 14:06:49 EDT
Yes, I'll test whatever you create.  As for what you create though... it looks like there are 30+ updates since the last release of 2.0.3.

Obviously I need the "Load bzImages smaller than 32 KiB" patch, not sure if it requires some or most of the others though.  I wish they would just do another release.
Comment 5 Fedora Update System 2012-10-25 05:59:01 EDT
kexec-tools-2.0.3-47.fc17.4 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.3-47.fc17.4
Comment 6 Fedora Update System 2012-10-25 06:00:44 EDT
kexec-tools-2.0.3-58.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.3-58.fc18
Comment 7 joshua 2012-10-29 20:39:12 EDT
Yes! kexec can now load bzImage kernels smaller than 32768 bytes... thank you
Comment 8 Fedora Update System 2012-11-07 20:58:17 EST
kexec-tools-2.0.3-47.fc17.4 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-11-08 01:10:03 EST
kexec-tools-2.0.3-58.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Admin XMLRPC Client 2013-02-25 03:06:51 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.