Bug 865216 - [abrt]: WARNING: at lib/kobject.c:196 kobject_add_internal+0x1f4/0x260(): TAINTED G W
[abrt]: WARNING: at lib/kobject.c:196 kobject_add_internal+0x1f4/0x260(): TAI...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:ecaeab5e0436ce187856c2c6e7f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 23:49 EDT by Mitch Skinner
Modified: 2013-01-02 13:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 13:29:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitch Skinner 2012-10-10 23:49:16 EDT
Description of problem:
tried to use a bluetooth keyboard

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.4-2.fc17.x86_64 root=UUID=53ecd9d9-6192-4a57-af70-706f0303ae23 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet radeon.audio=1
kernel:         3.5.4-2.fc17.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Taint on warning.

backtrace:
:WARNING: at lib/kobject.c:196 kobject_add_internal+0x1f4/0x260()
:Hardware name: System Product Name
:kobject_add_internal failed for hci0:11 with -EEXIST, don't try to register things with the same name in the same directory.
:Modules linked in: nls_utf8 udf snd_hrtimer snd_seq_midi snd_seq_midi_event snd_seq_dummy sha256_generic dm_crypt btrfs libcrc32c zlib_deflate hfsplus hfs minix vfat msdos fat jfs xfs reiserfs fuse hidp lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_usb_audio snd_hda_codec snd_usbmidi_lib snd_hwdep snd_rawmidi snd_seq snd_seq_device raid10 snd_pcm snd_page_alloc snd_timer snd btusb bluetooth coretemp kvm_intel i2c_i801 soundcore lpc_ich rfkill r8169 mii mfd_core kvm asus_atk0110 microcode serio_raw uinput firewire_ohci firewire_core ata_generic pata_acpi crc_itu_t pata_marvell radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 22048, comm: kworker/u:2 Tainted: G        W    3.5.4-2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81058746>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff812d0264>] kobject_add_internal+0x1f4/0x260
: [<ffffffff812d9351>] ? vsnprintf+0x461/0x600
: [<ffffffff81093010>] ? enqueue_entity+0xc0/0x440
: [<ffffffff812d0637>] kobject_add+0x67/0xc0
: [<ffffffff813b28f9>] device_add+0x119/0x6e0
: [<ffffffff813b10a1>] ? dev_set_name+0x41/0x50
: [<ffffffffa029ca94>] hci_conn_add_sysfs+0x54/0xc0 [bluetooth]
: [<ffffffffa028e8e0>] hci_conn_complete_evt.isra.46+0xe0/0x3c0 [bluetooth]
: [<ffffffffa02914a8>] hci_event_packet+0xee8/0x2680 [bluetooth]
: [<ffffffffa029b9af>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
: [<ffffffff814f1417>] ? __kfree_skb+0x47/0xa0
: [<ffffffff814f14a6>] ? kfree_skb+0x36/0xa0
: [<ffffffffa029b9af>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
: [<ffffffffa0283b48>] hci_rx_work+0x1e8/0x430 [bluetooth]
: [<ffffffff81075fc9>] process_one_work+0x129/0x400
: [<ffffffffa0283960>] ? hci_send_frame+0xc0/0xc0 [bluetooth]
: [<ffffffff810765f6>] worker_thread+0x126/0x2e0
: [<ffffffff810764d0>] ? rescuer_thread+0x1f0/0x1f0
: [<ffffffff8107b633>] kthread+0x93/0xa0
: [<ffffffff816161e4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107b5a0>] ? flush_kthread_worker+0x80/0x80
: [<ffffffff816161e0>] ? gs_change+0x13/0x13
Comment 1 Henry Hemming 2012-10-20 07:36:04 EDT
Bluetooth keyboard and mouse paired and working using the bluez_simple_test script. Seemingly random crashes of bluetooth keyboard (but not mouse) keeps occuring, at an interval of a few hours. restarting etc/init.d/rfcomm fixes it, also logging out (from X session) fixes it.

The only potential accessories to the crime could chrome, spotify, or android debug bridge, tho no great correlation with any of them except that they are constly in use.

Only non default repo programs are : oracle jdk 6.x, chrome stable, android debug bridge, spotify (converted from .deb). Clean install from a few days ago, no mods.


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Josh Boyer 2013-01-02 12:24:37 EST
The backtrace is some kind of device hotplug/removal race, as it is just a warning that a kobject with that specific name already exists.

Are you still seeing this with the 3.6.11 or newer kernel updates?
Comment 3 Mitch Skinner 2013-01-02 12:48:37 EST
Haven't seen this one in a while, no.  I'm not on 3.6.11 yet (currently on 3.6.10); I'm not even sure when I stopped seeing this.  I've also moved away from bluetooth since it's been a pain on F17.
Comment 4 Josh Boyer 2013-01-02 13:29:03 EST
I'm going to close this out then.  If you see it again, please let us know.

Note You need to log in before you can comment on or make changes to this bug.