Bug 865291 - FATAL ERRORL python callback <bound method RPMCallback.callback of < pyanaconda.packaging.yumpayload.RPMCallback object at ..> failed
FATAL ERRORL python callback <bound method RPMCallback.callback of < pyanacon...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 03:14 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 23:45:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (130.00 KB, application/x-tar)
2012-10-11 03:14 EDT, Jiri Moskovcak
no flags Details
used kickstart (4.11 KB, text/plain)
2012-10-11 03:16 EDT, Jiri Moskovcak
no flags Details

  None (edit)
Description Jiri Moskovcak 2012-10-11 03:14:22 EDT
Created attachment 625359 [details]
Logs

Description of problem:
Installing from kickstart and the erro in summary is what I get.

File "/tmp/updates/pyanaconda/packaging/yumpayload.py" line 1450 in callback pyanaconda.packaging.PayloadInstallError: cpio, unpack or fatal script error

Version-Release number of selected component (if applicable):
tested the following nightly builds:
20121009
20121010

How reproducible:
always

Steps to Reproduce:
1. start installation with attached kickstart
2.
3.
  
Actual results:
exception

Expected results:
installed system
Comment 1 Jiri Moskovcak 2012-10-11 03:16:38 EDT
Created attachment 625362 [details]
used kickstart
Comment 2 Chris Lumens 2012-10-11 15:55:17 EDT
We're not going to be able to fix the underlying error, but we definitely need to handle the exception and display something useful.  I also see we do not appear to have logged the problem either.

However I'm going to need to wait on this until msivak is done sorting out some threading issues, since what he's doing there will directly influence what kind of patch I make for this.
Comment 3 Fedora Update System 2012-10-16 23:07:23 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 4 Fedora Update System 2012-10-17 13:28:24 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-17 22:36:22 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 6 Fedora Update System 2012-10-18 11:28:14 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-10-19 21:32:13 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 8 Adam Williamson 2012-11-22 23:45:45 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.
Comment 9 Steve Tyler 2013-07-20 08:32:07 EDT
For the record:

Add an error handler for fatal package installation errors (#865291).
https://git.fedorahosted.org/cgit/anaconda.git/commit/?id=9c41febe5747587046871d9525e8d4e66a7befb9

Note You need to log in before you can comment on or make changes to this bug.