Bug 865325 - bug reporting from text mode doesn't work
bug reporting from text mode doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2012-10-11 04:50 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-12 13:04:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2012-10-11 04:50:18 EDT
Description of problem:
Recently i ran into a problem during the installation from text mode and anaconda just died with an exception without giving me a chance to use the reporting tool to report the bug to bugzilla, so I had to do it manually (rhbz#865291)

Version-Release number of selected component (if applicable):
tested with nightly builds:
20121009
20121010

How reproducible:
100%

Steps to Reproduce:
- described in #865291
  
Actual results:
- the exception is just printed on screen, but there is no way to report it to bugzilla

Expected results:
- the report tool kicks in, asks for bz credentials and creates the bz ticket with all required logs

Additional info:
- not sure if this is problem with the new text mode not using the python-meh or in libreport
Comment 1 Vratislav Podzimek 2012-10-11 05:04:16 EDT
It was decided that text mode in F18 is really minimalistic and bug reporting will be available in F19.
Comment 2 Martin Banas 2012-10-12 04:59:21 EDT
Hello,

would it be at least possible for F18 not to reboot the machine if traceback happens? If it's not a hard task, it would really help with debugging.

Thanks.
Comment 3 Vratislav Podzimek 2012-10-12 05:09:37 EDT
(In reply to comment #2)
> Hello,
> 
> would it be at least possible for F18 not to reboot the machine if traceback
> happens? If it's not a hard task, it would really help with debugging.
> 
> Thanks.
'nokill' boot option should prevent reboot. Until we have some better exception handling (with bug reporting) in text mode, I'm afraid this is the only option.
Comment 4 Jesse Keating 2012-10-17 17:21:49 EDT
We /might/ make textmode default to nokill, because there is no way to report the errors.  Hopefully for F19 we'll have some way to do error reporting in text mode.
Comment 6 Vratislav Podzimek 2013-01-15 08:37:58 EST
Patches for python-meh and anaconda posted to anaconda-patches.
Comment 7 Adam Williamson 2013-05-12 13:04:55 EDT
As it happens, I tried this the other day, and I was able successfully to file a traceback from text mode. Closing.

Note You need to log in before you can comment on or make changes to this bug.