This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865388 - Static archives don't contain debuginfo
Static archives don't contain debuginfo
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: elfutils (Show other bugs)
DTS 1.1 RHEL 5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 06:21 EDT by Petr Machata
Modified: 2015-05-04 21:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No release note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 09:39:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Machata 2012-10-11 06:21:32 EDT
Description of problem:
brp-strip-static-archives strips static archives.  The solution is to rename them so that this rpmbuild script doesn't find them.  Linker scripts need to be updated accordingly.  I verified that when named .ar instead of .a, the linker (both BFD and gold) can still use these archives as libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 6 errata-xmlrpc 2013-01-22 09:39:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0174.html

Note You need to log in before you can comment on or make changes to this bug.