Bug 865423 - Subscribing an available pool after importing a Expired cert says "[Errno 2] No such file or directory: '/etc/pki/entitlement/1845482705944796227.pem'"
Subscribing an available pool after importing a Expired cert says "[Errno 2] ...
Status: CLOSED DUPLICATE of bug 852630
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
IDM QE LIST
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-10-11 08:09 EDT by Shwetha Kallesh
Modified: 2012-10-16 11:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 11:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Expiredcert (3.39 KB, application/x-x509-ca-cert)
2012-10-11 08:09 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Shwetha Kallesh 2012-10-11 08:09:01 EDT
Created attachment 625488 [details]
Expiredcert

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.[root@localhost pki]# subscription-manager register --org=admin
Username: admin
Password: 
The system has been registered with id: 4ac9fa9b-f5fa-4c6d-9d51-812ace2eb24e 
[root@localhost pki]# subscription-manager import --certificate=/root/Expiredcert.pem 
Successfully imported certificate Expiredcert.pem
[root@localhost pki]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Shared File System Bits
Product ID:           	88888
Version:              	1.0
Arch:                 	ALL
Status:               	Expired
Starts:               	
Ends:                 	

Product Name:         	Multiplier Product Bits
Product ID:           	917571
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

2.[root@localhost pki]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Awesome OS for x86_64
SKU:                  	awesomeos-x86_64
Pool Id:              	8ac6a3db3a4e43b5013a4e4481f40369
Quantity:             	5
Service Level:        	
Service Type:         	
Multi-Entitlement:    	Yes
Ends:                 	10/11/2013
Machine Type:         	physical

3.Subscription Name:    	Management Add-On
SKU:                  	management-100
Pool Id:              	8ac6a3db3a4e43b5013a4e447e34025c
Quantity:             	1000
Service Level:        	
Service Type:         	
Multi-Entitlement:    	No
Ends:                 	10/11/2013
Machine Type:         	physical

 [root@localhost ~]# subscription-manager subscribe --pool 8ac6a3db3a4e43b5013a4e447e34025c
[Errno 2] No such file or directory: '/etc/pki/entitlement/1845482705944796227.pem'
Successfully consumed a subscription for: Management Add-On


[root@localhost ~]# ls /etc/pki/entitlement/
757015369918277928-key.pem  757015369918277928.pem
Actual results:


Expected results:


Additional info:
Comment 1 Michael Stead 2012-10-11 08:14:44 EDT
While the error is harmless, and we are successfully subscribed, the error message would likely leave the user wondering if something went wrong.
Comment 2 RHEL Product and Program Management 2012-10-11 08:28:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 RHEL Product and Program Management 2012-10-16 09:18:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Devan Goodwin 2012-10-16 11:51:45 EDT

*** This bug has been marked as a duplicate of bug 852630 ***

Note You need to log in before you can comment on or make changes to this bug.