This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865454 - Cannot manage tomcat7's deployed web applications
Cannot manage tomcat7's deployed web applications
Status: CLOSED DUPLICATE of bug 921261
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: JON Plugin (Show other bugs)
unspecified
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Jean-frederic Clere
Mike Foley
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 09:29 EDT by Jan Martiska
Modified: 2013-04-25 22:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ?? Consequence: For the ZIP version of JBoss Enterprise Web Server, all deployed web applications unexpectedly appear "unavailable" and management operations applies to them are ineffective. As an example, a stop operation on a running web application results in the following error: Fix: None Result: None Workaround: None
Story Points: ---
Clone Of:
: 921261 (view as bug list)
Environment:
Last Closed: 2013-04-12 12:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2012-10-11 09:29:14 EDT
Tomcat7 version: JBoss EWS 2.0.0.CR1 (installed from ZIP)
All deployed webapps appear as 'unavailable'. And it looks like no management operations on them work. For example invoking a 'stop' operation on a running webapp will end with:

java.lang.IllegalStateException: Could not find MBean for WAR '//localhost/my-simple-webapp'.
	at org.jboss.on.plugins.tomcat.TomcatWarComponent.invokeOperation(TomcatWarComponent.java:350)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:634)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)

By the way, deploying new applications works fine, but you cannot manage them after that anymore.
Comment 1 mark yarborough 2012-11-12 15:22:32 EST
This bug needs a corresponding bug in Jira or Bz (as appropriate) owned by the plugin team. Mark Yarborough work with John Doyle to define EWS owner.
Comment 2 Rémy Maucherat 2012-12-14 11:31:57 EST
Both work for me now, and were likely caused by bad mbean names. The mbean names got fixed by the Tomcat 7 support patch. If there is a problem, a new bug should be filed using a build that uses the RHQ version that has acked support for Tomcat 7.
Comment 3 Libor Fuka 2013-01-18 07:43:55 EST
Do we have this patch in EWS 2.0.0.GA ?
I think no.
Comment 4 Larry O'Leary 2013-03-13 15:28:56 EDT
Web applications are shows as unavailable due to the stateName value being returned as "STARTED" when for whatever reason, we are expecting "1".
Comment 6 Larry O'Leary 2013-04-12 12:06:56 EDT
Closing this as it duplicates the already cloned bug that had been captured in EWS.

*** This bug has been marked as a duplicate of bug 921261 ***

Note You need to log in before you can comment on or make changes to this bug.