Bug 865462 - IPv6 address cannot be specified within the cluster configuration with upper case letters
IPv6 address cannot be specified within the cluster configuration with upper ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks: 928849 895075
  Show dependency treegraph
 
Reported: 2012-10-11 09:57 EDT by Pierguido Lambri
Modified: 2013-09-30 18:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: rgmanager-2.0.52-42.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 895075 (view as bug list)
Environment:
Last Closed: 2013-09-30 18:36:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierguido Lambri 2012-10-11 09:57:45 EDT
Description of problem:
When trying to use a ipv6 address in the cluster configuration, when activated
it returns an error:

Oct  2 16:06:49 server clurgmgrd[10732]: <notice> start on ip "FC00:0000:0000:0000:0:0:0:150/64" returned 1 (generic error)

Version-Release number of selected component (if applicable):
rgmanager-2.0.52-28.el5

How reproducible:
Always

Steps to Reproduce:
1. Configure in the cluster an ipv6 address all upper case
2. Try to start the service with the IP

  
Actual results:
The service fails.

Expected results:
The IP should be set independently of upper/lower case 

Additional info:

The RFC http://tools.ietf.org/html/rfc4291 permits both lower and upper cases.
Comment 2 RHEL Product and Program Management 2012-10-11 10:08:52 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 RHEL Product and Program Management 2012-10-30 01:52:15 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2013-09-30 18:36:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1316.html

Note You need to log in before you can comment on or make changes to this bug.