Bug 865466 - usb flash disk changed device name after resume form suspend
usb flash disk changed device name after resume form suspend
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 10:05 EDT by Dalibor Pospíšil
Modified: 2012-11-12 15:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 15:56:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (70.72 KB, application/octet-stream)
2012-10-11 10:05 EDT, Dalibor Pospíšil
no flags Details
dmidecode (14.23 KB, application/octet-stream)
2012-10-11 10:07 EDT, Dalibor Pospíšil
no flags Details
dmesg_t420s (149.04 KB, text/plain)
2012-10-15 09:19 EDT, Jaroslav Škarvada
no flags Details
dmidecode (14.22 KB, text/plain)
2012-10-15 09:32 EDT, Jaroslav Škarvada
no flags Details

  None (edit)
Description Dalibor Pospíšil 2012-10-11 10:05:27 EDT
Created attachment 625547 [details]
dmesg

Description of problem:
usb flash disk chande device after resume from suspend if booted from live in yellow charging USB port (back side on Lenovo T520) 

Version-Release number of selected component (if applicable):
kernel-3.6.1-1.fc18.i686


How reproducible:
always

Steps to Reproduce:
1. pm-suspend
2. resume
3.
  
Actual results:
/dec/sdb changes to /dev/sdc

Expected results:
no change

Additional info:
Comment 1 Dalibor Pospíšil 2012-10-11 10:07:22 EDT
Created attachment 625548 [details]
dmidecode
Comment 2 Jaroslav Škarvada 2012-10-15 09:18:22 EDT
I encountered similar problem on Lenovo T420s. I got the flash disk partition renamed from /dev/sdb1 to /dev/sdc1 after several suspend/hibernate/suspend to both/resume cycles that rendered my live system unusable (due to rename). Thus it seems not to be 100% reproducible on my system. I had the flash disk connected to yellow charging USB port, but I am not sure whether it is the real source of the problem (I will retry to reproduce this with regular USB port).
Comment 3 Jaroslav Škarvada 2012-10-15 09:19:58 EDT
Created attachment 627414 [details]
dmesg_t420s
Comment 4 Jaroslav Škarvada 2012-10-15 09:32:35 EDT
Created attachment 627429 [details]
dmidecode
Comment 5 Josh Boyer 2012-11-12 15:56:28 EST
This is USB doing device re-enumeration.  There really isn't anything that can be done here.  We'd suggest you use UUIDs or labels for devices instead of raw device nodes.

Note You need to log in before you can comment on or make changes to this bug.