Bug 86549 - curl instructions lead to iso to stdout
Summary: curl instructions lead to iso to stdout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: Red Hat Satellite QA List
URL: https://rhn.redhat.com/network/softwa...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-25 12:52 UTC by Philip Long
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-01 15:57:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Philip Long 2003-03-25 12:52:52 UTC
Description of problem:

curl -C - -O 'very_long_url'

As suggested on the web page sends the iso to STDOUT. (At least for the phoebe
curl).   Probably not what anyone wants.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. curl -C - -O 'very_long_url'
2.
3.
    
Actual results:
iso goes to STDOUT

Expected results:

iso goes to appopriately named file

Additional info:

Reccomended fix:

Change instructions to read

curl -C - -O 'very_long_url' >  filename.iso

Comment 1 Mihai Ibanescu 2003-03-25 14:39:06 UTC
Are you positively sure this sends to stdout? Don't be confused by the apparent
stray dash after -C. man curl shows:

              Use "-C -" to tell curl to automatically  find  out
              where/how  to resume the transfer. It then uses the
              given output/input files to figure that out.

Also we recommend using -O:

       -O/--remote-name
              Write  output to a local file named like the remote
              file we get. (Only the file part of the remote file
              is used, the path is cut off.)

              You  may  use this option as many times as you have
              number of URLs.

I did not manage to make the output come to stdout unless I explicitly dropped
the - after -C.

Comment 2 Philip Imants Long 2003-03-25 19:21:57 UTC
Yup, this is what I used:

curl -C --O 'very_long_url'

(which is what it looks like under phoebe and an LCD, on a CRT it is clearly a
stray '-') as opposed to

curl -C - -O 'very_long_url'




Comment 3 Mihai Ibanescu 2003-03-31 22:07:53 UTC
Well. please do try with the stray -, this is what the documentation says,
doesn't it?

Comment 4 Bret McMillan 2003-03-31 22:29:44 UTC
Also, use 'O' vs '0'... zero is bad :(

Comment 5 Philip Long 2003-04-01 13:41:50 UTC
Yes, it works fine with the proper syntax.  I was just "faked into" using
improper syntax as the stray - did not seem to have a space between it and the -O.



Comment 6 Josef Komenda 2003-04-01 15:57:19 UTC
We've cleaned up the documentation on this page to try and prevent this from
happening again. Closing. 


Note You need to log in before you can comment on or make changes to this bug.