Bug 865501 - Problems after yum upgrade from F17 to F18.
Problems after yum upgrade from F17 to F18.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 11:34 EDT by Endi Sukma Dewata
Modified: 2013-01-14 13:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 13:35:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Endi Sukma Dewata 2012-10-11 11:34:35 EDT
There are several problems that happen after upgrading a F17 desktop VM to F18 using yum, they may or may not be related:

1. httpd cannot be started, but there is no message logged in /var/log/httpd/error_log.
2. Logging out from the desktop will not bring back the login screen. It looks like gdm failed to start.
3. If you restart the VM it will get stuck at boot time, it will show the messages about starting the services, but it won't bring up the desktop login screen.

SELinux is in permissive mode. dmesg shows many lines like this:

  [34015.998096] systemd-journald[305]: Failed to parse log priority line.
Comment 1 Michal Schmidt 2012-10-11 11:38:00 EDT
The first thing to check here is the initramfs. Make sure to regenerate it using F18's dracut.
Comment 2 Lennart Poettering 2013-01-14 13:35:17 EST
Please retry with a more recent F18 version. If the problems persist, please file individual reports about the issues you encounter. I will close this one for now.

Note You need to log in before you can comment on or make changes to this bug.