From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Description of problem:
When trying to update the rpm packages on RH7.3 using the rpm-4.0.5 packages
there is an error because the dependency on python is not satisfied
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Download updated packages from ftp://ftp.rpm.org/pub/rpm/test-4.0.5
2. rpm -Fvh <packages>
[root@vectra rpm]# rpm -Fvh *4.0.5*.7x.i386.rpm popt-1.6.5-0.1.7x.i386.rpm
error: failed dependencies:
python >= 2.2 is needed by rpm-python-4.0.5-0.1.7x
popt = 1.6.4 is needed by rpm-perl-4.0.4-7x.18
rpm = 4.0.4 is needed by rpm-perl-4.0.4-7x.18
The rpm-python pacakge should probably depend on "python2>=2.2"
The rpm-perl packages is not supplied in the updates so I had to remove it -
perhaps it should be supplied or obsoleted?
[root@vectra rpm]# rpm -q python
[root@vectra rpm]# rpm -q python2
Actually, rpm-4.0.5 needs python 1.5, not python2.
Fixed in rpm-4.0.5-1 errata, thanks for checking and reporting.