This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865551 - Can't add a disk to a VM error message contains '${diskAliases}' instead of the disks' aliases [TEXT]
Can't add a disk to a VM error message contains '${diskAliases}' instead of t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Vered Volansky
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 14:19 EDT by Simon Grinberg
Modified: 2016-02-10 12:23 EST (History)
9 users (show)

See Also:
Fixed In Version: SI22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Grinberg 2012-10-11 14:19:21 EDT
Description of problem:
Error while executing action: Cannot add Virtual Machine Disk: The disks ${diskAliases} are locked. Please try again in a few minutes.

Version-Release number of selected component (if applicable):
SI 20 

How reproducible:
Always. 

Steps to Reproduce:
1. Create a VM from a template - use clone 
2. While the VM is locked try to add a new disk
3.
  
Actual results:
Operation blocked, error message does no substitute the variable with the name of the locked disk 

Expected results:
Operation should succeed, the VM is down. The fact that the other disk is locked should not prevent the creation and attachment of another disk.

If the above is considered an RFE then at least fix the Error message to name the locked disk, and let's clone this as an RFE for future. 
 

Additional info:
Comment 1 Simon Grinberg 2012-10-11 14:35:10 EDT
More info:
The disk was actually created after some time I don't know why it took few minuets until it appeared in the disks tab in the GUI, just not attached to the VM meaning a floating disk is created, so the error message is totally misleading.

I suspect that this happens since ad new disc in VM context is a composite operation. The first the async create which was allowed, and then the attach which got blocked due to the other disk being locked.

Changing the title accordingly.
Comment 2 Simon Grinberg 2012-10-11 15:10:28 EDT
Ignore comment #1 , I could not re-create or find evidence in the log, or at least I can see in the log the creation of the unattached disk was initiated later, probably from other attempt.
Comment 4 Vered Volansky 2012-10-18 14:43:21 EDT
Fixed error message to: VM is locked. Please try again in a few minutes.
This error message can be seen when reproducing the original bug description.

Change-Id: Ib7a82d91b0ee51ebd1a612dbf210e0ea4533e746

http://gerrit.ovirt.org/#/c/8666/
Comment 5 Vered Volansky 2012-10-22 01:21:08 EDT
Fixed error message to:

Error while executing action: Cannot add Virtual Machine Disk: The disks vm1_Disk2, vm1_Disk1 are locked. Please try again in a few minutes.

1. Created a VM using clone.
2. Added a disk to that VM while it's being created.

Results in the above message.

The new disk was not created, not even after a while.

Change-Id: Ib7a82d91b0ee51ebd1a612dbf210e0ea4533e746
http://gerrit.ovirt.org/#/c/8666/
Comment 6 Allon Mureinik 2012-10-22 02:42:06 EDT
Merged Ib7a82d91b0ee51ebd1a612dbf210e0ea4533e746
Comment 7 Dafna Ron 2012-10-28 09:42:02 EDT
verified on si22.1

Note You need to log in before you can comment on or make changes to this bug.