Bug 865554 - stl types are not displayed via libstdcxx printers.py
stl types are not displayed via libstdcxx printers.py
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: insight (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Monnerat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 14:26 EDT by Stan Cox
Modified: 2012-11-23 22:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:25:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stl string test (124 bytes, text/x-c++src)
2012-10-11 14:26 EDT, Stan Cox
no flags Details

  None (edit)
Description Stan Cox 2012-10-11 14:26:28 EDT
Created attachment 625625 [details]
stl string test

Description of problem:
A stl type, e.g. a string, is not displayed using the libstdcxx printers.py:
 insight -n a.out
 ...<and in the console window>
 (gdb) print hello
$1 = {static npos = <optimized out>, _M_dataplus = {<std::allocator<char>> = {<__gnu_cxx::new_allocator<char>> = {<No data fields>}, <No data fields>}, _M_p = 0x602028 "Ni Hao"}}


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. g++ hello.cxx
2. insight -n ./a.out
3. b 8
   run
   print hello
  
Actual results:


Expected results:
print hello
"Ni hao"

Additional info:
Comment 1 Keith Seitz 2012-10-11 15:11:32 EDT
This is happening because the insight executable was built without python support:

$ insight -nw -q
(gdb) python print hello
Python scripting is not supported in this copy of GDB.
Comment 2 Patrick Monnerat 2012-11-15 14:14:34 EST
@Keith: thanks for the hint, you saved me a lot of investigations :-)
Comment 3 Fedora Update System 2012-11-15 14:15:42 EST
insight-7.4.50-4.20120403cvs.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/insight-7.4.50-4.20120403cvs.fc17
Comment 4 Fedora Update System 2012-11-15 14:16:01 EST
insight-7.4.50-4.20120403cvs.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/insight-7.4.50-4.20120403cvs.fc16
Comment 5 Fedora Update System 2012-11-15 14:16:21 EST
insight-7.4.50-4.20120403cvs.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/insight-7.4.50-4.20120403cvs.fc18
Comment 6 Fedora Update System 2012-11-16 02:29:24 EST
Package insight-7.4.50-4.20120403cvs.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing insight-7.4.50-4.20120403cvs.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18300/insight-7.4.50-4.20120403cvs.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-11-23 02:25:27 EST
insight-7.4.50-4.20120403cvs.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-11-23 22:31:34 EST
insight-7.4.50-4.20120403cvs.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-11-23 22:33:34 EST
insight-7.4.50-4.20120403cvs.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.