Bug 865579 - python-greenlet segfaults on ppc64
Summary: python-greenlet segfaults on ppc64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-greenlet
Version: 17
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lev Shamardin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 819726 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-11 20:02 UTC by Paulo de Rezende Pinatti
Modified: 2013-02-07 10:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 865643 (view as bug list)
Environment:
Last Closed: 2012-12-13 15:09:55 UTC
Type: Bug


Attachments (Terms of Use)
Backported commit b17773a (3.73 KB, patch)
2012-10-11 20:02 UTC, Paulo de Rezende Pinatti
no flags Details | Diff
Backport of pull request https://github.com/python-greenlet/greenlet/pull/7 (3.49 KB, text/plain)
2013-02-07 10:44 UTC, IBM Bug Proxy
no flags Details

Description Paulo de Rezende Pinatti 2012-10-11 20:02:21 UTC
Created attachment 625672 [details]
Backported commit b17773a

Description of problem:

Whenever the library's switch function is used it segfaults. How to reproduce:

>>> from greenlet import greenlet
>>> def test():
...     print 12
... 
>>> def run():
...     gr = greenlet(test)
...     gr.switch()
... 
>>> run()
12
Segmentation fault


Version-Release number of selected component (if applicable): 0.3.1-9.fc17


How reproducible: always

There is already a fix available upstream. The package can either be updated to the 0.4.0 version or the commit b17773a can be cherry-picked. A backported version of the commit is attached.

Comment 1 Fedora Update System 2012-10-12 00:01:50 UTC
python-greenlet-0.3.1-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-greenlet-0.3.1-11.fc17

Comment 2 Fedora Update System 2012-10-12 00:02:44 UTC
python-greenlet-0.3.1-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-greenlet-0.3.1-11.fc18

Comment 3 Fedora Update System 2012-10-12 00:03:18 UTC
python-greenlet-0.3.1-11.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-greenlet-0.3.1-11.el6

Comment 4 Fedora Update System 2012-10-12 17:58:25 UTC
Package python-greenlet-0.3.1-11.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-greenlet-0.3.1-11.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16027/python-greenlet-0.3.1-11.fc18
then log in and leave karma (feedback).

Comment 5 Paulo de Rezende Pinatti 2012-10-19 18:40:17 UTC
It seems the updated package wasn't pushed to the ppc64 repositories. I am able to see it on the x86 repository though. Maybe some ppc64 tag is missing in the build?

Comment 6 Kevin Fenzi 2012-10-19 18:54:46 UTC
In Fedora, ppc is a secondary arch. They follow behind the primary arch... 
so there could well be some delay before it's built. 

Check ppc.koji.fedoraproject.org for progress.

Comment 7 Paulo de Rezende Pinatti 2012-11-14 19:00:41 UTC
Package reached repositories and I was able to successfully test it on Fedora 17.

Comment 8 Pádraig Brady 2013-02-07 10:41:43 UTC
*** Bug 819726 has been marked as a duplicate of this bug. ***

Comment 9 IBM Bug Proxy 2013-02-07 10:44:46 UTC
Created attachment 694386 [details]
Backport of pull request https://github.com/python-greenlet/greenlet/pull/7


Note You need to log in before you can comment on or make changes to this bug.