Bug 865594 - iSCSI CHAP information not applied to additional Hosts
iSCSI CHAP information not applied to additional Hosts
Status: CLOSED DUPLICATE of bug 852753
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.1.0
Assigned To: Nobody's working on this, feel free to take it
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 17:02 EDT by Steve Reichard
Modified: 2016-02-10 15:25 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 03:26:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Reichard 2012-10-11 17:02:39 EDT
Description of problem:


I am not sure if this is a beta issue (could be related to Bug 852753) or existed previously.

We have CHAP configured on our EMC celerra. (Had to disable dual-auth since RHEV doesn't support it still, Bug 602224).

Adding first host seem quite normal.  However adding a second host becomes a problem. It seems that the new host does not adopt the
CHAP creds of the  existing hosts in the DC.  Upon adding/authorizing the new HOST become non-responsive, since it can not join the storage
domain.
  
I've been able to work around by

    creating a new DC,
    put the added host into this DC,
    start to add a New Storage domain to the DC using the added hosts
    provide creds
    discover and login
    cancel add the domain
    move the added host back the the originall DC
    activate
    It comes up!

Seem a bit much.



Due to a netowrk issue that happened just before I started entering this BZ, I can not get more version info or logs until it is addressed.  (I will be OOO for a bit, so I wanted to get this in as a palce holder for now).


Version-Release number of selected component (if applicable):


rhevm - '3.1.0-14.el6ev'
rhel mgmt agents - 4.9.6-36.0.el6_3
rhevh - rhevh-6.3-20120910.0.rhev31.el6_3.iso



How reproducible:


easily in this config





Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ayal Baron 2012-10-14 03:26:30 EDT
This is a dup of bug 852753 as the credentials are just not stored in the db.

*** This bug has been marked as a duplicate of bug 852753 ***

Note You need to log in before you can comment on or make changes to this bug.