Bug 8656 - [Bug 4689] slow network transfer using tar to remote host
[Bug 4689] slow network transfer using tar to remote host
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-20 09:24 EST by Robert K. Moniot
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 13:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert K. Moniot 2000-01-20 09:24:24 EST
On 01/13/00 22:44 pbrown@redhat.com wrote:
> +we never were able to duplicate this.  If you are still having problems,
> or the
> +problem was not solved in 6.1, please reopen the bug.

I want to reopen this bug. It has not gone away with 6.1.

I found a way to demo this problem without need of a tape drive.  We
have two systems here, named pascal and sobolev.  Both are Compaq
Deskpros with CPU >= 300 MHz, running RedHat 6.1.  They are connected
via Netelligent 10/100 TX (tlan) network interfaces, to a LAN via CAT5
UTP (10base-T), so neither cpu nor network bandwidth are problems.
They share account information via NIS.

Procedure:

Given filesystems:
   1) /u/pascal that is local to pascal and NFS mounted by sobolev.
      A suitably large subdirectory foo (25 MB) is located in this
      filesystem, and is to be backed up onto a file on sobolev.
   2) /tmp is local to sobolev, and is to receive the backup file.

The procedures below are executed as a normal user with an account on
both hosts, and permission to run r-commands on sobolev (e.g. via
the .rhosts mechanism).

Slow method:

Logged in on host pascal, chdir to local filesystem /u/pascal.

pascal:/u/pascal/$ time tar cf sobolev:/tmp/remote.tar foo
0.750u 2.350s 1:11.49 4.3%      0+0k 0+0io 7433pf+0w


Fast method:

On host sobolev, chdir to the NFS filesystem pascal:/u/pascal.
sobolev:/u/pascal/$ time tar cf /tmp/nfs.tar foo
0.320u 2.990s 0:37.12 8.9%      0+0k 0+0io 187pf+0w

sobolev:/u/pascal/$ ls -l /tmp/*.tar
-rw-r--r--   1 moniot   staff    25937920 Jan 14 12:17 /tmp/nfs.tar
--w---xr--   1 moniot   staff    25937920 Jan 14 12:15 /tmp/remote.tar*


Do the math:
  Slow method: 26 MB/ 71 s = 370 KB/s
  Fast method: 26 MB/ 37 s = 700 KB/s

The numbers vary a bit depending on system and network load, but the
basic difference remains.  With the tape drive we are seeing a bigger
difference (a factor of 3 to 4), but that seems to be due to the tape
drive being on an alpha-OSF system.

(The permissions of remote.tar look a bit odd too, now that I notice
them.  But never mind that now.)

--

Bob Moniot
Fordham University               email:  moniot@fordham.edu
Fordham College Lincoln Center   URL: http://www.dsm.fordham.edu/~moniot/
New York, NY  10023              phone:  (212) 636-6311
Comment 1 Preston Brown 2000-02-11 11:46:59 EST
jeff or bero:  do you have time to investigate this?
Comment 2 Bernhard Rosenkraenzer 2000-02-11 12:29:59 EST
Not today (config tool freeze) - maybe later.
Comment 3 Preston Brown 2000-05-05 13:34:59 EDT
Bero:  please investigate.
Comment 4 Bernhard Rosenkraenzer 2000-08-08 12:23:51 EDT
This is normal NFS overhead in the way tar works (opening a series of small
files over nfs has a lot of overhead); can't be fixed.

Note You need to log in before you can comment on or make changes to this bug.