Bug 865625 - [abrt] PackageKit-0.8.4-3.fc18: pk_backend_cancel: Process /usr/libexec/packagekitd was killed by signal 11 (SIGSEGV)
[abrt] PackageKit-0.8.4-3.fc18: pk_backend_cancel: Process /usr/libexec/packa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:b0f4dd52533fa3adc06ddd74a83...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 18:38 EDT by D. Charles Pyle
Modified: 2013-12-16 21:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 05:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.98 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: environ (92 bytes, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: event_log (952 bytes, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: backtrace (19.30 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: cgroup (154 bytes, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: maps (28.61 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: dso_list (5.74 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: proc_pid_status (890 bytes, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: var_log_messages (2.32 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: open_fds (547 bytes, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details
File: build_ids (2.52 KB, text/plain)
2012-10-11 18:38 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-11 18:38:35 EDT
Description of problem:
This crash has been happening repeatedly. I got a reprieve for about a day and it is back to crashing repeatedly every time I try to install software or try to use gpk-update-viewer to update. The crashes occur right in the middle of installs and updates.

Version-Release number of selected component:
PackageKit-0.8.4-3.fc18

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: pk_backend_cancel
kernel:         3.6.1-1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (8 frames)
: #0 pk_backend_cancel at pk-backend-zif.c:1858
: #1 pk_transaction_cancel at pk-transaction.c:3243
: #2 pk_transaction_method_call at pk-transaction.c:5392
: #3 call_in_idle_cb at gdbusconnection.c:4737
: #7 g_main_context_iteration at gmain.c:3351
: #8 pk_transaction_plugin_phase at pk-transaction.c:961
: #9 pk_transaction_run at pk-transaction.c:2143
: #10 pk_transaction_list_run_idle_cb at pk-transaction-list.c:318
Comment 1 D. Charles Pyle 2012-10-11 18:38:37 EDT
Created attachment 625719 [details]
File: core_backtrace
Comment 2 D. Charles Pyle 2012-10-11 18:38:39 EDT
Created attachment 625720 [details]
File: environ
Comment 3 D. Charles Pyle 2012-10-11 18:38:41 EDT
Created attachment 625721 [details]
File: event_log
Comment 4 D. Charles Pyle 2012-10-11 18:38:43 EDT
Created attachment 625722 [details]
File: limits
Comment 5 D. Charles Pyle 2012-10-11 18:38:44 EDT
Created attachment 625723 [details]
File: backtrace
Comment 6 D. Charles Pyle 2012-10-11 18:38:46 EDT
Created attachment 625724 [details]
File: cgroup
Comment 7 D. Charles Pyle 2012-10-11 18:38:48 EDT
Created attachment 625725 [details]
File: maps
Comment 8 D. Charles Pyle 2012-10-11 18:38:49 EDT
Created attachment 625726 [details]
File: dso_list
Comment 9 D. Charles Pyle 2012-10-11 18:38:51 EDT
Created attachment 625727 [details]
File: proc_pid_status
Comment 10 D. Charles Pyle 2012-10-11 18:38:52 EDT
Created attachment 625728 [details]
File: var_log_messages
Comment 11 D. Charles Pyle 2012-10-11 18:38:53 EDT
Created attachment 625729 [details]
File: open_fds
Comment 12 D. Charles Pyle 2012-10-11 18:38:55 EDT
Created attachment 625730 [details]
File: build_ids
Comment 13 D. Charles Pyle 2012-10-11 18:40:42 EDT
I had to log on as root to get this report out. abrt refused to show it or allow me to file a report until I did so.
Comment 14 D. Charles Pyle 2012-11-24 21:00:20 EST
Have no idea what is happening but PackageKit errors are frequent.
I have experienced problems with PackageKit off and on since Fedora 14.
I wasn't doing anything except browsing the web when abrt showed the error.


backtrace_rating: 4
Package: PackageKit-0.8.4-7.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 15 D. Charles Pyle 2012-11-24 21:02:21 EST
Have no idea what is happening but PackageKit errors are frequent.
I have experienced problems with PackageKit off and on since Fedora 14.
I wasn't doing anything except browsing the web when abrt showed the error.
This is the second error in a few seconds.


backtrace_rating: 4
Package: PackageKit-0.8.4-7.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 16 Richard Hughes 2013-12-10 12:22:23 EST
Does this still happen with f19+?
Comment 17 D. Charles Pyle 2013-12-11 04:46:43 EST
I no longer am using Fedora 19.  Next spate of updates for F20, I'll check using gpk-update.  I had stopped using the gpk applications to update or install software.
Comment 18 D. Charles Pyle 2013-12-11 04:56:50 EST
Just as I had posted the above, I saw that there were three new updates for KDE available.  I did not this time see a crash during the update using gpk-update.
Comment 19 Richard Hughes 2013-12-11 05:47:17 EST
Okay, please re-open if it happens again. Thanks.
Comment 20 D. Charles Pyle 2013-12-16 21:41:09 EST
I am not seeing the error previously but any updates or even local installs using PackageKit are slow as molasses in winter.  I just updated three small packages and it took well over six minutes, including scanning all repositories even for a purely local install.  Before that it took several minutes before the system even showed that PackageKit was doing anything.  At least it isn't crashing, though.

Note You need to log in before you can comment on or make changes to this bug.