Bug 865648 - Project-wide search and replace: "Select all" should be consistent with the actual selection after a new search
Project-wide search and replace: "Select all" should be consistent with the a...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity low
: ---
: 2.0
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 22:03 EDT by Ding-Yi Chen
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121119-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-10-11 22:03:54 EDT
Description of problem:

If you check the "select all" button on the previous project-wide search, after the new search,  the "select all" will still checked , however, the search results are not actually checked. This is inconvent because you need to toggle "Select all" 2 times to replace all.


Version-Release number of selected component (if applicable):
Zanata version 1.8.0-SNAPSHOT (20121012-0031)

How reproducible:
Always


Steps to Reproduce:
1. Visit a doucment 
2. Viist the project-wide search by click at the search icon.
3. Type any term in the search field
4. Check "Search all"
5. Click "Search"
6. Type a different term in the serach field
7. Click "Search"
  
Actual results:
"Search All" is still checked, but the search results are not actuall checked.


Expected results:
Either uncheck the "Search all", or select all the search results.


Additional info:
Comment 1 David Mason 2012-11-06 02:39:01 EST
Fixed in 2.0.3-SNAPSHOT

See https://github.com/zanata/zanata/commit/517440020acab551a647e4523648bed4cd0b602d
Comment 2 Ding-Yi Chen 2012-11-08 00:42:21 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121108-1439)
Comment 3 Sean Flanigan 2012-11-12 02:47:37 EST
Please test on 2.0.x.
Comment 4 Ding-Yi Chen 2012-11-19 00:51:53 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121119-0019)

Note You need to log in before you can comment on or make changes to this bug.