This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865665 - host boot fail and when system boots with kernel parameter intel_iommu=on
host boot fail and when system boots with kernel parameter intel_iommu=on
Status: CLOSED DUPLICATE of bug 865666
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Don Dutile
Red Hat Kernel QE team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 01:07 EDT by FuXiangChun
Modified: 2013-01-09 07:10 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 22:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host serial console log (225.46 KB, text/plain)
2012-10-15 22:21 EDT, FuXiangChun
no flags Details
lspci and dmesg log (94.82 KB, text/plain)
2012-10-15 22:50 EDT, FuXiangChun
no flags Details

  None (edit)
Description FuXiangChun 2012-10-12 01:07:08 EDT
Description of problem:

As subject. and cann't get useful infomation from monitor. I attached host serial console log.

Hit this issue with kernel-2.6.32-328.el6、kernel-2.6.32-320.el6 and kernel-2.6.32-325.el6. 
For kernel-2.6.32-279.el6(GA kernel), It works well and haven't hit this issue. 
Since kvm QE have tested device assignment and don't hit this issue on rhel6.3 GA
so add 'regression' keywords.
Currently, kvm QE want to test 'device assignment' with the latest kernel, because this bug we cann't continue. so add 'blocker' flags.

Version-Release number of selected component (if applicable):
host kernel:
kernel-2.6.32-328.el6
kernel-2.6.32-320.el6
kernel-2.6.32-325.el6. 

How reproducible:
100%

Steps to Reproduce:
1.boot system with  kernel parameter intel_iommu=on
2.
3.
  
Actual results:
boot fail, and monitor cann't get useful infomation.

Expected results:
boot successfully.

Additional info:
Comment 2 Alex Williamson 2012-10-15 10:38:48 EDT
Is this on any system at all or on a particular type of system?  Moving to kernel since this is a host IOMMU bug.
Comment 3 Alex Williamson 2012-10-15 12:15:22 EDT
2.6.32-329.el6.x86_64 boots fine on my system with intel_iommu=on, maybe something x2apic related?
Comment 4 Don Dutile 2012-10-15 13:52:33 EDT
I don't see attached console log.

Please also provide:
lspci, lspci -vvv, lspci -t output
dmesg log when no intel_iommu=on

Try a boot with 'intel_iommu=strict'
Comment 5 FuXiangChun 2012-10-15 22:21:09 EDT
Created attachment 627914 [details]
host serial console log
Comment 6 FuXiangChun 2012-10-15 22:49:27 EDT
(In reply to comment #4)
> I don't see attached console log.
I attached a console log.

> Please also provide:
> lspci, lspci -vvv, lspci -t output
> dmesg log when no intel_iommu=on
> 
This log file include lspci, lspci -vvv, lspci -t output and dmesg information.

> Try a boot with 'intel_iommu=strict'

host boot successfully and work well.
Comment 7 FuXiangChun 2012-10-15 22:50:53 EDT
Created attachment 627916 [details]
lspci and dmesg log
Comment 8 juzhang 2012-10-17 22:26:16 EDT
Talked to the reporter, the reporter filed the two same( bz865666 and bz865665) bug by mistaking. Close one

*** This bug has been marked as a duplicate of bug 865666 ***

Note You need to log in before you can comment on or make changes to this bug.