Bug 865679 - [RFE] Ability to use distro default fstype even if ondisk= is used
[RFE] Ability to use distro default fstype even if ondisk= is used
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity medium (vote)
: 0.11
: ---
Assigned To: Dan Callaghan
Qixiang Wan
Kickstart
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 02:14 EDT by Jun'ichi NOMURA
Modified: 2013-01-16 23:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 23:33:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to implement fstype= kickstart metadata (2.26 KB, patch)
2012-10-12 02:14 EDT, Jun'ichi NOMURA
no flags Details | Diff

  None (edit)
Description Jun'ichi NOMURA 2012-10-12 02:14:00 EDT
Created attachment 625806 [details]
A patch to implement fstype= kickstart metadata

Description of problem:

For testing purpose, we would like to use default fstype of distro.
(e.g. ext3 for RHEL5, ext4 for RHEL6)

However, if ondisk=/partitions= kickstart metadata is used,
rhts_partitions snippet forces all partitions to ext3.

Attached patch removes the fixed fstype and lets the distro installer
select fstype even when ondisk= and/or partitions= are used.
And for flexibility, 'fstype=' kickstart metadata is added:
  - when used with ondisk= and/or partitions=, it specifies fstype of
    '/' and '/boot'
  - for partitions created by 'partitions=' metadata,
    fstype metadata is used as default file system for those partitions
Comment 1 Dan Callaghan 2012-10-12 02:20:38 EDT
Thanks for the patch, Jun'ichi!
Comment 2 Dan Callaghan 2012-11-26 20:20:16 EST
On Gerrit: http://gerrit.beaker-project.org/1511
Comment 5 Dan Callaghan 2012-12-03 21:41:56 EST
(In reply to comment #4)
> The faulty statement seems to be line no 54 of rhts_partitions: 
> 
> {% set myfstype = %}
> 
> If I set it to {% set myfstype = 'ext3'%}, it seems to be working fine, but
> I am not sure if that defeats the purpose of this fix. 

The best thing would be to set it to '' or None, which is the intention of that line anyway. I am still not sure why this syntax is accepted by Jinja on my box but not on yours...
Comment 6 Dan Callaghan 2012-12-03 22:40:56 EST
(In reply to comment #5)

The breakage only happens on Jinja 2.6.

http://gerrit.beaker-project.org/1531
Comment 9 Qixiang Wan 2012-12-25 03:00:19 EST
Verified with build beaker-0.10.6-1.git.95.9d3b913.el6.

[1] With ks_meta="ondisk=vda fstype=ext3", after system provision (RHEL6.3, the default fstype for which is ext4):

# df -T
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/vda3     ext3     6022268   1944280   3772068  35% /
tmpfs        tmpfs      510368         0    510368   0% /dev/shm
/dev/vda1     ext3      198337     28230    159867  16% /boot


[2] With ks_meta="ondisk=vda fstype=ext3 partitions=/mnt/block1:part:1;mylvm:lvm:1;/mnt/block4ext4:part:1:ext4":

# df -T
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/vda3     ext3     2920952   1871180    901396  68% /
tmpfs        tmpfs      510368         0    510368   0% /dev/shm
/dev/vda1     ext3      198337     28231    159866  16% /boot
/dev/vda6     ext3     1032088     34096    945564   4% /mnt/block1
/dev/vda7     ext4     1029048     17668    959108   2% /mnt/block4ext4
/dev/mapper/TestVolume001-mylvm
              ext3     1032088     34096    945564   4% /mylvm
Comment 10 Dan Callaghan 2013-01-16 23:33:33 EST
Beaker 0.11.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.