Bug 865687 - Set CA with the value which is the same as URL, RHEV-H hung on the window of "Applying Configuration".
Set CA with the value which is the same as URL, RHEV-H hung on the window of ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 03:00 EDT by chencong
Modified: 2013-02-28 11:32 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously when a hypervisor tried to register with a Satellite server, and no certificate path was included in the Satellite URI, a recursive WGET command was used to try and find and download the certificate. This behaviour left users stuck on the "Applying configuration" screen, with no way to cancel the registration. The WGET command used to download the Satellite's certificate is no longer recursive, and now fails if an invalid certificate path is given.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:32:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hung on the window of "Applying Configuration" (24.36 KB, image/png)
2012-10-12 03:00 EDT, chencong
no flags Details

  None (edit)
Description chencong 2012-10-12 03:00:21 EDT
Created attachment 625819 [details]
hung on the window of "Applying Configuration"

Description of problem: 
Register satellite input valid username, password and URL, set CA with the value which is the same as URL. RHEV-H hung on the window of "Applying Configuration". 

Version-Release number of selected component (if applicable): 
rhev-hypervisor 6-6.3-20121010.2.el6_3 
rhev-hypervisor 6-6.3-20121005.0.el6_3 

How reproducible: 
100% 

Steps to Reproduce: 
1. Install RHEV-H. 
2. Configure network, set CA with the value which is the same as URL "https://10.66.73.127" . 
3. RHEV-H hung on the window of "Applying Configuration", unable to respond to the F2 key. 

Actual result: 
RHEV-H hung on the window of "Applying Configuration". 

Expect result: 
Should pop-up an error when the registration is not successful for a long time. 

Additional info: 
Valid CA info:https://10.66.73.127/pub/RHN-ORG-TRUSTED-SSL-CERT 
If set CA with the other invalid URL, there will pop up a message to prompt user "RHN Configuration Failed", this problem just occur when set CA field to https://10.66.73.127.
Comment 4 haiyang,dong 2012-10-29 05:01:23 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Steps 
1. Install RHEV-H. 
2. Configure network,Register satellite input valid username, password and URL,  set CA with the value which is the same as URL "https://10.66.73.127" . 

it will prompt that "RHN Configuration Failed. Check ovirt.log for details"

So this issue about "Set CA with the value which is the same as URL, RHEV-H hung on the window of "Applying Configuration"" has been fixed, change bug status to VERIFIED.

but the root cause is that "CACert" didn't exist from wget link for rhn sat cert, no valuable information was offered in ovirt.log, have reported another bug 870938 to track it.
Comment 5 haiyang,dong 2012-12-26 06:39:33 EST
so follow steps of comment 4 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 8 errata-xmlrpc 2013-02-28 11:32:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.