Bug 865692 - [abrt] git-1.7.11.7-1.fc17: handle_curl_result: Process /usr/libexec/git-core/git-remote-http was killed by signal 11 (SIGSEGV)
[abrt] git-1.7.11.7-1.fc17: handle_curl_result: Process /usr/libexec/git-core...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:a2ef3e05a7d8753ee23d7243e77...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 03:12 EDT by Robin Lee
Modified: 2013-04-30 19:52 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 01:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.10 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: environ (3.70 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: backtrace (10.59 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: maps (15.54 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: dso_list (3.14 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: build_ids (1.52 KB, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: open_fds (874 bytes, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details
File: var_log_messages (337 bytes, text/plain)
2012-10-12 03:12 EDT, Robin Lee
no flags Details

  None (edit)
Description Robin Lee 2012-10-12 03:12:08 EDT
Description of problem:
Try to 'git clone http://git.1wt.eu/git/haproxy-1.3.git/'

Version-Release number of selected component:
git-1.7.11.7-1.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        git-remote-http origin http://git.1wt.eu/git/haproxy-1.3.git/
crash_function: handle_curl_result
kernel:         3.6.1-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 handle_curl_result at http.c:751
: #1 http_request at http.c:821
: #2 http_request_reauth at http.c:836
: #3 http_get_strbuf at http.c:844
: #4 http_get_info_packs at http.c:986
: #5 fetch_indices at http-walker.c:385
: #6 fetch_pack at http-walker.c:406
: #7 fetch at http-walker.c:527
: #8 loop at walker.c:176
: #9 walker_fetch at walker.c:287
Comment 1 Robin Lee 2012-10-12 03:12:11 EDT
Created attachment 625829 [details]
File: core_backtrace
Comment 2 Robin Lee 2012-10-12 03:12:14 EDT
Created attachment 625830 [details]
File: environ
Comment 3 Robin Lee 2012-10-12 03:12:16 EDT
Created attachment 625831 [details]
File: limits
Comment 4 Robin Lee 2012-10-12 03:12:18 EDT
Created attachment 625832 [details]
File: backtrace
Comment 5 Robin Lee 2012-10-12 03:12:20 EDT
Created attachment 625833 [details]
File: cgroup
Comment 6 Robin Lee 2012-10-12 03:12:23 EDT
Created attachment 625834 [details]
File: maps
Comment 7 Robin Lee 2012-10-12 03:12:25 EDT
Created attachment 625835 [details]
File: dso_list
Comment 8 Robin Lee 2012-10-12 03:12:28 EDT
Created attachment 625836 [details]
File: build_ids
Comment 9 Robin Lee 2012-10-12 03:12:30 EDT
Created attachment 625837 [details]
File: open_fds
Comment 10 Robin Lee 2012-10-12 03:12:32 EDT
Created attachment 625838 [details]
File: var_log_messages
Comment 11 Enrico Scholz 2012-10-12 10:13:07 EDT
seeing this too.  Seems to be a race in

| static int http_request(...
|		run_active_slot(slot);
|		ret = handle_curl_result(slot);


On fast or cached connections, run_active_slot() can download the pack completely, frees 'slot' and starts download of objects immediately by using the allocated 'slot' object.  handle_curl_result() expects the original 'slot' and crashes.
Comment 12 Enrico Scholz 2012-10-12 10:22:14 EDT
Explanation is not correct, but problem is

run_active_slot() -> finish_active_slot() -> process_object_response() -> start_object_request() -> start_active_slot()

call chain
Comment 13 Enrico Scholz 2012-10-12 10:37:31 EDT
https://github.com/git/git/commit/88097030725bf68d1801559cfb4785b93a50f5f8 is responsible for the crash (formerly, the 'results' on stack very used, now the 'results' within the slot object which are modified by the call chain above).
Comment 14 Dominic Cleal 2012-10-18 14:26:40 EDT
I ran the following:

$ git clone http://oss.tresys.com/git/refpolicy.git
Cloning into 'refpolicy'...

It only ran for a second or so with the message above, then crashed.


backtrace_rating: 4
Package: git-1.7.11.7-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Marco Nolden 2012-10-19 04:31:43 EDT
I invoked git pull on a repo that was cloned before the latest git update from a http url. I also tried to clone again, doesn't work either.

backtrace_rating: 4
Package: git-1.7.12.1-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 16 John Whitehouse 2012-11-13 06:20:49 EST
Running the following command caused the problem:
git clone http://gnuradio.org/git/gnuradio.git

I can replicate the error in a Fedora 17 i686 VM (Virtualbox 4.2.4 r81684) as well as on my native i686 Fedora 17 install.

This Fedora Forums post covers the problems I see on my system accurately:
git clone http://gnuradio.org/git/gnuradio.git

Information from my syslog:
Nov 13 09:16:41 blue kernel: [ 5014.537033] git-remote-http[7360]: segfault at 0 ip 0804e783 sp bf9bada0 error 4 in git-remote-http[8045000+9b000]
Nov 13 09:16:41 blue abrt[7362]: Saved core dump of pid 7360 (/usr/libexec/git-core/git-remote-http) to /var/spool/abrt/ccpp-2012-11-13-09:16:41-7360 (10207232 bytes)




backtrace_rating: 4
Package: git-1.7.11.7-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Václav Mocek 2012-11-13 17:56:26 EST
The same problem here:

git clone http://luajit.org/git/luajit-2.0.git

git-1.7.11.7-1.fc17.i686
Comment 18 Fedora Update System 2012-11-22 10:47:33 EST
git-1.7.11.7-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/git-1.7.11.7-2.fc17
Comment 19 Fedora Update System 2012-11-22 22:08:19 EST
Package git-1.7.11.7-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-1.7.11.7-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18847/git-1.7.11.7-2.fc17
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2012-11-29 01:08:44 EST
git-1.7.11.7-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.