Bug 865711 - Transfer function doesn't work in octave 3.6.3 Fedora 17
Transfer function doesn't work in octave 3.6.3 Fedora 17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: octave-control (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Sailer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 04:39 EDT by Caner Çuhac
Modified: 2012-12-20 10:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:29:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caner Çuhac 2012-10-12 04:39:57 EDT
Description of problem:

The transfer function eg. tf([1], [1 1]) gives error in octave 3.6.3. Downgrading octave to 3.6.1 works perfect.

Version-Release number of selected component (if applicable):

3.6.3

How reproducible:

Start octave 3.6.3 and type tf([1], [1 1])

Steps to Reproduce:
1. Start octave 3.6.3 and type tf([1], [1 1])
  
Actual results:
Error.

Expected results:
Answer.

Additional info:
Downgrading to 3.6.1 solves the issue.
Comment 1 Orion Poplawski 2012-10-12 16:12:30 EDT
The transfer fuction comes from the octave-crontrol package which, since it is not packaged by Fedora, must have been installed by you, perhaps in a location where octave 3.6.3 does not look at?  What does "pkg list" show?
Comment 2 Caner Çuhac 2012-10-12 17:31:02 EDT
By "pkg list" if you mean which octave packages are installed, I used command:

$ rpm -qa | grep octave

octave-3.6.1-2.fc17.i686
octave-symbolic-1.1.0-2.fc17.i686
octave-control-2.2.4-2.fc17.i686

It seems that octave-control is packaged by Fedora. I did not do external installation.
Comment 3 Orion Poplawski 2012-10-12 17:39:04 EDT
My bad.  Looks like a newer octave-control is needed.  Thomas - I'll let you handle that if you would.  Thanks.
Comment 4 Fedora Update System 2012-10-13 05:43:19 EDT
octave-control-2.4.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/octave-control-2.4.0-1.fc18
Comment 5 Fedora Update System 2012-10-13 05:43:30 EDT
octave-control-2.4.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/octave-control-2.4.0-1.fc17
Comment 6 Thomas Sailer 2012-10-13 06:13:26 EDT
Your example actually works for me with:
octave-control-2.2.4-2.fc17.x86_64
octave-3.6.3-2.fc17.x86_64
Comment 7 Fedora Update System 2012-10-13 17:07:15 EDT
Package octave-control-2.4.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing octave-control-2.4.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16065/octave-control-2.4.0-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-20 10:29:08 EST
octave-control-2.4.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.