This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865717 - New kernel (kernel-3.6.1-1.fc17.x86_64) causes Skype sounds to have background noise
New kernel (kernel-3.6.1-1.fc17.x86_64) causes Skype sounds to have backgroun...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 04:51 EDT by Kolos Tatar
Modified: 2013-03-12 15:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 15:17:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kolos Tatar 2012-10-12 04:51:29 EDT
Description of problem:

This morning I upgraded to the latest Fedora kernel as usual (kernel-3.6.1-1.fc17.x86_64). After rebooting with the new kernel I noticed that Skype started having some background noise in every sound it tried to make.

The normal Pulseaudio test passed fine.

I reverted back to kernel 3.5.6-1 and the problem is gone. It's got to do something with the new kernel.

Version-Release number of selected component (if applicable):

kernel-3.6.1-1.fc17.x86_64
skype-4.0.0.8-fc16.i586

How reproducible:

Always

Steps to Reproduce:
1. Start Skype
2. Try to make a test call or test sound
  
Actual results:

Noise in Skype sounds

Expected results:

Clear Skype sounds

Additional info:
Comment 1 Ron Petrick 2012-10-12 05:56:48 EDT
I have the same problem when I run amarok. The problem disappears with the 3.5.6-1 kernel.
Comment 2 Franco Violi 2012-10-13 03:12:54 EDT
I have the same problem, on a Dell xps17. As above, The problem disappears with the 3.5.6-1 kernel.
Comment 3 Mykola Dvornik 2012-10-15 07:16:02 EDT
Seems like the problem is indeed in pulseaudio. ALSA output works just fine, while PulseAudio output produces either no sound or highly distorted one.

Here are the short list of versions of major components:

kernel.x86_64         3.6.1-1.fc17
pulseaudio.x86_64     1.1-9.fc17 
alsa-lib.x86_64       1.0.26-1.fc17
Comment 4 Kolos Tatar 2012-10-15 07:21:16 EDT
Mykola,

I would argue that the problem is with the kernel as the Pulseaudio test passes fine and Pulseaudio didn't get upgraded the morning I installed the new kernel.

Kolos
Comment 5 Mykola Dvornik 2012-10-15 07:44:15 EDT
Kolos,

Yes you are right from this point of view. But 3.6 has some core changes, which might make pulseaudio unhappy about.

In addition:

I have different two laptops Dell L502x and Dell L702x. The former produces no sound at all with PulseAudio output, while the later one works more or less OK (at least in Audacious and Chrome) and do have significant audio distortion in Skype only.
Comment 6 Kolos Tatar 2012-10-15 07:50:22 EDT
Mykola,

Probably you have a better overview of the problem so if you think it's not the kernel that needs some changes rolled back, but rather Pulseaudio needs some changes to work properly with the new kernel, then fine, please change the component of this bug and assign it appropriately.

Kolos
Comment 7 Kolos Tatar 2012-10-19 04:54:57 EDT
Rather interestingly with the latest kernel (3.6.2-4.fc17.x86_64) the problem disappeared for me.

Has anyone fixed this?

Kolos
Comment 8 Mykola Dvornik 2012-10-19 05:05:59 EDT
For the ALC665 codec the problem is still there. Moreover, for the speakers the ALSA output is now disfunct, while headphones output works just fine.
Comment 9 Ron Petrick 2012-10-20 09:39:06 EDT
The problem also appears to be fixed for me with 3.6.2-4.fc17.x86_64 on a Samsung Ultrabook Series 5.
Comment 10 Mykola Dvornik 2012-10-20 11:21:23 EDT
Only kernel-3.7.0-0.rc1.git2.1.fc19.x86_64 makes Realtek ALC665 alive on Dell XPS L702x.

Note You need to log in before you can comment on or make changes to this bug.