Bug 865723 - Firefox icon disappears from dock after upgrade from F16 to F17
Firefox icon disappears from dock after upgrade from F16 to F17
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
: 865722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 05:03 EDT by Stas Sergeev
Modified: 2012-10-15 05:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 808894
Environment:
Last Closed: 2012-10-12 05:35:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stas Sergeev 2012-10-12 05:03:27 EDT
+++ This bug was initially created as a clone of Bug #808894 +++

After upgrading from F16 to F17 as per https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum, the Firefox icon which had previously been in my dock as one of my favorites disappeared. It was easy enough to restore it by running Firefox and right-clicking on it and doing "Add to favorites", but this probably shouldn't have been necessary.

--- Additional comment from otaylor@redhat.com on 2012-04-05 18:26:18 EDT ---

Hmm, the problem is that the Mozilla desktop file changed names from F16 to F17 - from mozilla-firefox.desktop to firefox.desktop.

We changed the default accordingly, but if you modified things from the default, then the old default was "fossilized" into your gsettings, and then loading mozilla-firefox failed.

There's no clean fix, but having the web browser vanish on upgrade is fairly serious, so I think we probably need a Fedora-specific patch that checks for mozilla-firefox.desktop when loading the key from GSettings and replaces it with firefox.desktop

--- Additional comment from otaylor@redhat.com on 2012-04-05 18:49:02 EDT ---

I pushed a patch to fedora-git:

* Thu Apr  5 2012 Owen Taylor <otaylor@redhat.com> - 3.4.0-2
- Change gnome-shell-favourite-apps-firefox.patch to also patch the JS code
  to handle the transition from mozilla-firefox.desktop to firefox.desktop.
  (#808894, reported by Jonathan Kamens)

Will be picked up next time we build a GNOME Shell.
Comment 1 Stas Sergeev 2012-10-12 05:04:34 EDT
I am still having this bug, but I use cinnamon.
Any chances the bug is still there in cinnamon,
and not fixed by the aforementioned patch?
Comment 2 Stas Sergeev 2012-10-12 05:05:55 EDT
*** Bug 865722 has been marked as a duplicate of this bug. ***
Comment 3 leigh scott 2012-10-12 05:35:35 EDT
(In reply to comment #1)
> I am still having this bug, but I use cinnamon.
> Any chances the bug is still there in cinnamon,
> and not fixed by the aforementioned patch?

I have added the js fix in cinnamon.git and will be present in the next cinnamon build


--- a/js/ui/appFavorites.js
+++ b/js/ui/appFavorites.js
@@ -24,6 +24,12 @@ AppFavorites.prototype = {
 
     _reload: function() {
         let ids = global.settings.get_strv(this.FAVORITE_APPS_KEY);
+        // Fedora: Replace old mozilla-firefox.desktop with firefox.desktop,
+        for (let i = 0; i < ids.length; i++) {
+            if (ids[i] == 'mozilla-firefox.desktop')
+                ids[i] = 'firefox.desktop'
+        }
+
         let appSys = Cinnamon.AppSystem.get_default();
         let apps = ids.map(function (id) {
                 let app = appSys.lookup_app(id);
Comment 4 Stas Sergeev 2012-10-12 11:36:23 EDT
It appears in favourites, but not in an Internet menu.
Would you please fix also this?
Comment 5 Stas Sergeev 2012-10-15 05:20:05 EDT
Nevermind: now seems to appear also in menu!
Thanks for the fix.

Note You need to log in before you can comment on or make changes to this bug.