Bug 865729 - missing '--ssl-certificate' option in qpid-cluster tool
missing '--ssl-certificate' option in qpid-cluster tool
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools (Show other bugs)
2.3
Unspecified Unspecified
high Severity high
: 2.3
: ---
Assigned To: Ken Giusti
Petr Matousek
:
Depends On:
Blocks: 850517
  Show dependency treegraph
 
Reported: 2012-10-12 05:19 EDT by Petr Matousek
Modified: 2013-03-19 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: qpid-tools-0.18-2
Doc Type: Bug Fix
Doc Text:
Cause: The '--ssl-certificate' command line option was not supported by the qpid-cluster command line tool. Consequence: The qpid-cluster command would fail when used with brokers configured to require client authentication (ssl-require-client-authentication=yes). Fix: Add the '--ssl-certificate' option to qpid-cluster, which allows the user to supply a SSL certificate for the qpid-cluster tool to use to authenticate against the broker. Result: The qpid-cluster tool can be used with brokers that require SSL authentication of clients.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:37:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2012-10-12 05:19:12 EDT
Description of problem:
Please see bug 850517, comment 9 and bug 850517, comment 13.
Due to bug 850517 is a unique rhel5 bug, I'm opening the issue also for rhel6.

Version-Release number of selected component (if applicable):
qpid-tools-0.18-1
python-qpid-0.18-1

How reproducible:
100%

Steps to Reproduce:
1. run qpid-cluster --help
  
Actual results:
There is no option how to provide the ssl certificate when using qpid-cluster tool

Expected results:
user can provide the ssl certifiace when using qpid-tool
Comment 2 Petr Matousek 2012-10-15 12:05:39 EDT
This issue has been fixed.
Tested on RHEL5.8 and RHEL6.3 (both i386 and x86_64). 

Packages used for testing:
qpid-tools-0.18-2
python-qpid-0.18-2

-> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.