This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865739 - tgtd: Can't login to target when configured to use iSNS.
tgtd: Can't login to target when configured to use iSNS.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Andy Grover
Bruno Goncalves
: Regression
Depends On:
Blocks: 961026
  Show dependency treegraph
 
Reported: 2012-10-12 05:48 EDT by Bruno Goncalves
Modified: 2013-11-21 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
tgtd now properly reports its exported targets if configured to report them to an iSNS server.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:28:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2012-10-12 05:48:40 EDT
Description of problem:
There is some regression.

on scsi-target-utils-1.0.24-2.el6.x86_64 the login do not work even with 1 LUN with 1 target.


Version-Release number of selected component (if applicable):
scsi-target-utils-1.0.24-2.el6.x86_64

How reproducible:
100%


#Previous version it works
scsi-target-utils-1.0.14-4.el6.x86_64

iscsiadm -m discoverydb -t isns -p 127.0.0.1 --discover
Starting iscsid:                                           [  OK  ]
127.0.0.1:3260,1 iqn.2009-10.com.redhat:storage-1
iscsiadm -m node -l
Logging in to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,3260] (multiple)
Login to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,3260] successful.


#Now it fails 
#(It seems the discovery is returning 0 to port)
scsi-target-utils-1.0.24-2.el6.x86_64

iscsiadm -m discoverydb -t isns -p 127.0.0.1 --discover
Starting iscsid:                                           [  OK  ]
127.0.0.1:0,1 iqn.2009-10.com.redhat:storage-1
iscsiadm -m node -l
Logging in to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,0] (multiple)
iscsiadm: Could not login to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,0].
iscsiadm: initiator reported error (8 - connection timed out)

---
Oct 12 05:01:06 storageqe-11 tgtd: print_scn_pdu(655) scn name: 36, iqn.1994-05.com.redhat:storageqe-11
Oct 12 05:01:07 storageqe-11 iscsid: connect to 127.0.0.1:0 failed (Connection refused)
Oct 12 05:01:10 storageqe-11 iscsid: connect to 127.0.0.1:0 failed (Connection refused)
Oct 12 05:01:14 storageqe-11 iscsid: connect to 127.0.0.1:0 failed (Connection refused)
Comment 1 RHEL Product and Program Management 2012-10-12 05:49:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Andy Grover 2013-08-27 18:37:58 EDT
proposed fix posted upstream, waiting for comments.
Comment 5 Bruno Goncalves 2013-08-30 13:03:48 EDT
Reproduced on scsi-target-utils-1.0.24-2.el6.x86_64

And verified fix on scsi-target-utils-1.0.24-8.el6.x86_64



iscsiadm -m discoverydb -t isns -p 127.0.0.1 --discover
127.0.0.1:3260,1 iqn.2009-10.com.redhat:storage-1

iscsiadm -m node -l
Logging in to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,3260] (multiple)
Login to [iface: isns_iface, target: iqn.2009-10.com.redhat:storage-1, portal: 127.0.0.1,3260] successful.
Comment 6 errata-xmlrpc 2013-11-21 17:28:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1684.html

Note You need to log in before you can comment on or make changes to this bug.