Bug 86575 - Apache Config tool problems with Virtual hosting
Apache Config tool problems with Virtual hosting
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-25 16:30 EST by Kevin Ericson
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-29 10:03:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Ericson 2003-03-25 16:30:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
When using the config tool (redhat-config-httpd) to set up virtual hosts does
not properly update httpd.conf directory options such as "MultiViews".




Version-Release number of selected component (if applicable):
1.0.1 R18

How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-httpd
2. click "Virtual hosts" tab"
3. click edit (or "add")
4. select "Directories" and "add"
5. choose an option (such as MultiViews)
6. click OK, click OK, click OK and Save
7. edit httpd.conf and view results

Actual Results:  under the directory for the "virtual" host you'll not see your
options. Example
<Directory "/var/www/html/mywebsite">
        Options Indexes MultiViews        
        AllowOverride None
        Allow from from all      
        Order allow,deny
</Directory>

Expected Results:  the httpd.conf looks like this...
<Directory "/var/www/html/mywebsite">       
        AllowOverride None
</Directory>

Additional info:

The net result is that virtual websites will not display properly unless the
full URL and page name are specified (ie http://www.mywebsite.com/index.html).
The work around is to hand edit httpd.conf and add the multiview command or add
a global directive of "DirectoryIndex index.html"
Comment 1 Kevin Ericson 2003-03-25 16:34:16 EST
and of course I swapped the "expected results" and the "actual results"...doh
Comment 2 Phil Knirsch 2003-10-29 10:03:38 EST
OK, found the problem. The Options tag was missing in the VirtualHosts directory
entry. I also found a problem with the Allow from and Deny from entries (writes
Allow from from all).

Fixed in redhat-config-httpd-1.1.0-5 and later.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.