Bug 865808 - Pulp id has already been taken
Pulp id has already been taken
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 09:40 EDT by Thom Carlin
Modified: 2014-09-18 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 11:21:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2012-10-12 09:40:40 EDT
Description of problem:

Promotions fail with "Pulp id has already been taken"

Version-Release number of selected component (if applicable):

pulp 1.1.12-1.el6cf

How reproducible:

Evertime once it fails

Steps to Reproduce:
1. Unclear, initial promotion failed, subsequent result in this error
2.
3.
  
Actual results:

"Pulp id has already been taken"

Expected results:

Changset properly promoted

Additional info:

Reported by user:
> pending?falsetask_typefinish_time2012-10-11
04:16:38stateerroruser_id0start_timeresulterrorsE11000 duplicate key
error index: pulp_database.packages.$_id_ dup key: { :
"d8a8a4a6-784c-40a2-95aa-a9fd7d2d80ab" }Traceback (most recent call
last): File
"/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line
418, in run result = self.callable(*self.args, **self.kwargs) File
"/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line
146, in _clone _sync(clone_id, progress_callback=progress_callback,
synchronizer=synchronizer) File
"/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line
283, in _sync progress_callback, synchronizer, max_speed, threads) File
"/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line
373, in fetch_content added_packages =
synchronizer.process_packages_from_source(repo_dir, repo_id, skip_dict,
progress_callback) File ...
Comment 4 Mike McCune 2012-10-22 12:19:28 EDT
moving to 2.0 since we aren't reliably reproducing this.  if it starts happening more often we can escalate
Comment 5 Justin Sherrill 2013-01-22 11:12:15 EST
Is this able to be reproduced?  I am not able to reproduce locally and without a reproducer or at least a katello-debug, there isn't much more we can do.
Comment 6 Thom Carlin 2013-01-22 11:21:38 EST
Agreed, closed.  We can reopen it if it reoccurs on 1.1.x

Note You need to log in before you can comment on or make changes to this bug.