This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865810 - [RFE] DC and Cluster selection for New Host / Edit Host
[RFE] DC and Cluster selection for New Host / Edit Host
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alexander Wels
movciari
infra
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 09:44 EDT by Laszlo Hornyak
Modified: 2016-01-19 10:35 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 10:35:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 41240 master MERGED webadmin: combine datacenter/cluster in host popup Never
oVirt gerrit 41950 master MERGED userportal,webadmin: new VM cluster combo Never

  None (edit)
Description Laszlo Hornyak 2012-10-12 09:44:15 EDT
Description of problem:

When selecting cluster and DC, there are two dropdown boxes to chose from. One could be enough, and it would be more user-friendly. It could render the DC / cluster like:

 - Datacenter 1
   - Cluster 1 in DC 1
   - Cluster 2 in DC 1
 - Datacenter 2
   - Cluster 1 in DC 2
   - Cluster 2 in DC 2
 - Datacenter 3 - no cluster here, so you can not select any

Once the DC concept is removed from the engine, it could be still important for a super-engine.
Comment 1 Itamar Heim 2013-04-14 03:00:48 EDT
michal - we've discussed as part part of new instance type dialog.
iirc, "cluster name (dc name)"
Comment 3 Michal Skrivanek 2014-10-13 07:08:00 EDT
VM dialog is already using this approach
Comment 4 Einav Cohen 2015-05-06 19:48:20 EDT
Need to copy the Data-Center/Cluster drop-down widget (as seen in e.g. the New VM dialog) to the New/Edit Host dialog, replacing the existing Cluster field and Data-Center field in the 'General' section. 

since Alexander is planning to update the entire structure of the 'General' section of the New/Edit Host dialog in the context of bug 1124878 anyway, assigning to him this BZ too, which is also a requested change in the 'General' section of the New/Edit Host dialog. 

@Oved[/Barak] - OK with you? if not - feel free to re-assign.
Comment 5 Oved Ourfali 2015-05-07 01:09:36 EDT
(In reply to Einav Cohen from comment #4)
> Need to copy the Data-Center/Cluster drop-down widget (as seen in e.g. the
> New VM dialog) to the New/Edit Host dialog, replacing the existing Cluster
> field and Data-Center field in the 'General' section. 
> 
> since Alexander is planning to update the entire structure of the 'General'
> section of the New/Edit Host dialog in the context of bug 1124878 anyway,
> assigning to him this BZ too, which is also a requested change in the
> 'General' section of the New/Edit Host dialog. 
> 
> @Oved[/Barak] - OK with you? if not - feel free to re-assign.

Yes.
Thanks!
Comment 6 Max Kovgan 2015-06-28 10:13:42 EDT
ovirt-3.6.0-3 release
Comment 7 movciari 2016-01-15 05:46:19 EST
we already have automation for this

Note You need to log in before you can comment on or make changes to this bug.