Bug 865819 - [abrt] entangle-0.4.1-1.fc18: Process /usr/bin/entangle was killed by signal 11 (SIGSEGV)
[abrt] entangle-0.4.1-1.fc18: Process /usr/bin/entangle was killed by signal ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: entangle (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
abrt_hash:d58b489bf367db4f26843c79d95...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 10:15 EDT by Ryan Lerch
Modified: 2013-03-04 17:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 17:37:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.53 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: environ (2.33 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: backtrace (28.23 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: maps (52.46 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: dso_list (10.72 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: proc_pid_status (928 bytes, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: var_log_messages (2.34 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details
File: open_fds (1.34 KB, text/plain)
2012-10-12 10:15 EDT, Ryan Lerch
no flags Details

  None (edit)
Description Ryan Lerch 2012-10-12 10:15:26 EDT
Description of problem:
Trying out entangle in f18 alpha, Entangle segfaults when starting up with the camera connected. also, if the camera is not connected before startup, entangle crashes when trying to connect it though the GUI.

The camera i am trying to use is a Nikon d5000.



Version-Release number of selected component:
entangle-0.4.1-1.fc18

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
backtrace_rating: 4
cmdline:        entangle
crash_function: entangle_camera_reset_last_error
kernel:         3.6.1-1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (9 frames)
: #0 entangle_camera_reset_last_error at backend/entangle-camera.c:586
: #1 do_entangle_camera_error at backend/entangle-camera.c:598
: #2 gp_context_error at gphoto2-context.c:279
: #3 gp_camera_get_manual at gphoto2-camera.c:983
: #4 entangle_camera_connect at backend/entangle-camera.c:695
: #5 entangle_camera_connect_helper at backend/entangle-camera.c:718
: #6 run_in_thread at gsimpleasyncresult.c:869
: #7 io_job_thread at gioscheduler.c:162
: #9 g_thread_proxy at gthread.c:797
Comment 1 Ryan Lerch 2012-10-12 10:15:29 EDT
Created attachment 626019 [details]
File: core_backtrace
Comment 2 Ryan Lerch 2012-10-12 10:15:31 EDT
Created attachment 626020 [details]
File: environ
Comment 3 Ryan Lerch 2012-10-12 10:15:37 EDT
Created attachment 626021 [details]
File: limits
Comment 4 Ryan Lerch 2012-10-12 10:15:39 EDT
Created attachment 626022 [details]
File: backtrace
Comment 5 Ryan Lerch 2012-10-12 10:15:41 EDT
Created attachment 626023 [details]
File: cgroup
Comment 6 Ryan Lerch 2012-10-12 10:15:43 EDT
Created attachment 626024 [details]
File: maps
Comment 7 Ryan Lerch 2012-10-12 10:15:45 EDT
Created attachment 626025 [details]
File: dso_list
Comment 8 Ryan Lerch 2012-10-12 10:15:47 EDT
Created attachment 626026 [details]
File: proc_pid_status
Comment 9 Ryan Lerch 2012-10-12 10:15:49 EDT
Created attachment 626027 [details]
File: var_log_messages
Comment 10 Ryan Lerch 2012-10-12 10:15:52 EDT
Created attachment 626028 [details]
File: open_fds
Comment 11 Glen Basshem 2012-11-08 06:17:51 EST
Pluged in a camera (Nikon coolpix 5700) via USB.
Then I  started entangle. 
A blank window appered than dissapered in less than 1 second.
Then the ABRT crash message appered.


backtrace_rating: 4
Package: entangle-0.4.1-1.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Glen Basshem 2012-11-08 16:09:34 EST
1 start entangle 
2 click on file>select camera
3 choose the camera (Kodak EasyShare DX4530)
4 crash

I tried with a different computer and camera it crashed after step 1 (see https://bugzilla.redhat.com/show_bug.cgi?id=865819)


backtrace_rating: 4
Package: entangle-0.4.1-1.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Jaap Bril 2013-02-14 11:05:09 EST
basedon yum install entangle (feb 13)
configure
1 start camera (and umount)
2 start entangle
3 crash

tried Canon 5d II and Canon ixus220hs (identical results)


*******
Comment 14 Jaap Bril 2013-02-14 11:06:13 EST
tried to build entangle & failed

download 878144 bytes entangle-0.5.0.tar.gz

unpack
configure
... requirements (gdk-pixbuf-2.0 >= 2.12.0) were not met:
No package 'gdk-pixbuf-2.0' found
fedora 18 is at 2.10.0

so no cigar.....
Comment 15 monts 2013-02-16 08:50:11 EST
Attached camera to USB cable and powered on ... launched Entangle .. segfaulted .. same happes with selinux=1 (system default) ... selinux=0 was passed to test if getting the same error. 

dmesg

[   98.912034] usb 2-5: new high-speed USB device number 2 using ehci_hcd
[   99.026785] usb 2-5: New USB device found, idVendor=04cb, idProduct=020f
[   99.026792] usb 2-5: New USB device strings: Mfr=0, Product=2, SerialNumber=3
[   99.026797] usb 2-5: Product: Digital Camera
[   99.026802] usb 2-5: SerialNumber: id 

dmesg

[  117.645173] pool[1379]: segfault at 58 ip 0000000000437b45 sp 00007ff668bac5a0 error 4 in entangle[400000+65000]

backtrace_rating: 4
cmdline:        /usr/bin/entangle
crash_function: entangle_camera_reset_last_error
executable:     /usr/bin/entangle
kernel:         3.7.7-201.fc18.x86_64
package:        entangle-0.5.0-1.fc18
reason:         Process /usr/bin/entangle was killed by signal 11 (SIGSEGV)
remote_result:  NOTFOUND
uid:            1000
Comment 16 Daniel Berrange 2013-02-21 17:03:49 EST
The cause of these crashes is that libgphoto2 changed its ABI / API, without changing the library soname. A rebuild of entangle against new API is required to fix the crash.


Based on the stack trace in initial description, there may be a second bug lurking here. Once a build with the crash solved is available, we can see about diagnosing any remaining bug.
Comment 17 Fedora Update System 2013-02-21 18:01:17 EST
entangle-0.5.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/entangle-0.5.0-3.fc18
Comment 18 Cristian Ciupitu 2013-02-22 12:23:10 EST
I connected a Canon PowerShot G15 camera to the USB port of my computer.

backtrace_rating: 4
Package: entangle-0.5.0-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 19 Daniel Berrange 2013-02-22 12:31:52 EST
@cristian: can you try the pending update entangle-0.5.0-3.fc18 to see if it improves matters.
Comment 20 Cristian Ciupitu 2013-02-22 13:07:33 EST
It stopped crashing.
Comment 21 Fedora Update System 2013-02-24 03:38:28 EST
Package entangle-0.5.0-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing entangle-0.5.0-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2911/entangle-0.5.0-3.fc18
then log in and leave karma (feedback).
Comment 22 Jaap Bril 2013-02-24 07:12:53 EST
No more crash; seems to work (testing takes time)
Comment 23 Glen Basshem 2013-02-25 20:49:48 EST
It still crashes with the Kodak EasyShare DX4530. I will try it with the Nikon later.

Installed Packages
entangle.i686                   0.5.0-3.fc18                    @updates-testing
Comment 24 Glen Basshem 2013-02-26 02:07:09 EST
It doesn't crash with a Nikon coolpix 5700 in PTP mode.

I can trigger and capture photos.
I can change the resolution, aperture, shutter speed, focal length, etc.

Some Glib warnings are displayed. (see below)

[glen@localhost ~]$ entangle

(entangle:19766): GLib-GObject-WARNING **: gsignal.c:2576: instance `0x89b8170' has no handler with id `1072693248'

(entangle:19766): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion `path != NULL' failed

(entangle:19766): GLib-GIO-CRITICAL **: g_file_create: assertion `G_IS_FILE (file)' failed

(entangle:19766): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(entangle:19766): GLib-GObject-WARNING **: gsignal.c:2576: instance `0x89b8170' has no handler with id `1073741824'

(entangle:19766): GLib-GObject-WARNING **: gsignal.c:2576: instance `0x89b8170' has no handler with id `1074266112'

(entangle:19766): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion `path != NULL' failed

(entangle:19766): GLib-GIO-CRITICAL **: g_file_create: assertion `G_IS_FILE (file)' failed

(entangle:19766): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(entangle:19766): GLib-GObject-WARNING **: gsignal.c:2576: instance `0x89b8170' has no handler with id `1074790400'

(eog:19825): EOG-CRITICAL **: eog_list_store_length: assertion `EOG_IS_LIST_STORE (store)' failed
Comment 25 Fedora Update System 2013-03-04 17:37:41 EST
entangle-0.5.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.