Bug 865834 - missing __init__.py in quantum
missing __init__.py in quantum
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-quantumclient (Show other bugs)
1.0 (Essex)
x86_64 Linux
unspecified Severity high
: ---
: 2.0 Folsom
Assigned To: RHOS Maint
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 11:02 EDT by Jaroslav Henner
Modified: 2013-07-03 22:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-quantumclient-2.1.10-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 10:28:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2012-10-12 11:02:43 EDT
Description of problem:
There is no way to import quantum.client without mangling the sys.path or PYTHONPATH or working directory. This is because there is missing __init__.py to indicate the directory is a python package.

I think the quantum.client should be importable to allow other projects to use it.


Version-Release number of selected component (if applicable):
python-quantumclient-2012.1-2.el6.noarch


How reproducible:
allways


Steps to Reproduce:
[root@slave ~]# rpm -q python-quantumclient
python-quantumclient-2012.1-2.el6.noarch
[root@slave ~]# python -c "import quantum.client"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named quantum.client
  

Actual results:
ImportError


Expected results:
Import suceed
[root@slave ~]# touch __init__.py /usr/lib/python2.6/site-packages/quantum/__init__.py
[root@slave ~]# python -c "import quantum.client"


Additional info:
Comment 1 Jaroslav Henner 2012-10-12 11:13:43 EDT
As apevec adviced `yum install python-quantum -y` helped. Thus python-novaclient is missing python-quantum as it's dep.

Note You need to log in before you can comment on or make changes to this bug.