Bug 865847 - XklWrapperError: 'ph ()' not in the list of added layouts
XklWrapperError: 'ph ()' not in the list of added layouts
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:d224d1e8f3f1f82d152a06bee3d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 11:48 EDT by Reartes Guillermo
Modified: 2012-10-15 03:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 17:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (281.80 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: storage.log (117.13 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: environ (764 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (2.53 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: syslog (73.56 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details
File: program.log (41.70 KB, text/plain)
2012-10-12 11:49 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-12 11:48:56 EDT
Description of problem:
Go to select keyboard layout, choose to add keyboard '+' and selected ALL keyboards.
All keyboards layout get added ok, even if it took a bit for it.
Then started to remove one by one and got this. 


Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 379, in remove_layout
:    raise XklWrapperError(msg)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/keyboard.py", line 258, in _removeLayout
:    self._xkl_wrapper.remove_layout(store[itr][0])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/keyboard.py", line 323, in on_remove_clicked
:    self._removeLayout(store, itr)
:XklWrapperError: 'ph ()' not in the list of added layouts
Comment 1 Reartes Guillermo 2012-10-12 11:49:05 EDT
Created attachment 626075 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-12 11:49:08 EDT
Created attachment 626076 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-12 11:49:10 EDT
Created attachment 626077 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-12 11:49:12 EDT
Created attachment 626078 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-12 11:49:17 EDT
Created attachment 626079 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-12 11:49:19 EDT
Created attachment 626080 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-12 11:49:21 EDT
Created attachment 626081 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-12 11:49:24 EDT
Created attachment 626082 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-12 11:49:28 EDT
Created attachment 626083 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-12 11:49:30 EDT
Created attachment 626084 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-12 11:49:32 EDT
Created attachment 626085 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-12 11:49:35 EDT
Created attachment 626086 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-12 11:49:37 EDT
Created attachment 626087 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-12 11:49:40 EDT
Created attachment 626088 [details]
File: program.log
Comment 15 Vratislav Podzimek 2012-10-12 17:48:32 EDT
Sorry, but this is not a reasonable use case. Moreover we just call libxklavier (chaning X runtime configuration) and it probably cannot handle so many layouts correctly.
Comment 16 Reartes Guillermo 2012-10-12 18:24:19 EDT
I do agree that it is not a reasonable usage case. (who will have so many keyboards? :-) )

Should anaconda prevent the user from doing know things that crashes the installer? 

At least there might be max number of keyboards that anaconda (for whatever reason) supports.
Comment 17 Vratislav Podzimek 2012-10-15 03:25:32 EDT
(In reply to comment #16)
> I do agree that it is not a reasonable usage case. (who will have so many
> keyboards? :-) )
> 
> Should anaconda prevent the user from doing know things that crashes the
> installer? 
> 
> At least there might be max number of keyboards that anaconda (for whatever
> reason) supports.
Well, this might be a problem, because it depends on X server itself and I'm affraid it may be arch-dependend.

Note You need to log in before you can comment on or make changes to this bug.