Bug 865896 - "Forgot Username" causes error
"Forgot Username" causes error
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 14:30 EDT by Thom Carlin
Modified: 2014-03-18 13:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
empty radio button in dialog (24.82 KB, image/png)
2012-10-31 10:44 EDT, Og Maciel
no flags Details

  None (edit)
Description Thom Carlin 2012-10-12 14:30:26 EDT
Description of problem:

When pressing "Send Login", receive "Couldn't find Organization with ID=1 [WHERE "organizations"."task_id" IS NULL]"

Version-Release number of selected component (if applicable):

CloudForms 1.1 beta

How reproducible:

Every time

Steps to Reproduce:
1. Setup userid per System Engine User manual with email address
2. Logoff
3. Click Forgot Username link
4. Enter email corresponding to 1
5. Click Send Login
  
Actual results:

"Couldn't find Organization with ID=1 [WHERE "organizations"."task_id" IS NULL]" error.  No email

Expected results:

Username reminder email to be sent

Additional info:
Comment 3 Thom Carlin 2012-10-13 20:50:06 EDT
Same error for "Forgot Password"
Comment 4 James Laska 2012-10-31 09:04:14 EDT
Thom, for future System Engine bugs, please attach the tarball created by the command /usr/share/katello/scripts/katello-debug.  That will provide diagnostic information crucial for debugging 

I'm unable to reproduce this problem using the following version of katello

 * katello-1.1.12-18.el6cf.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.1.8-1.el6cf.src.rpm
 * katello-cli-1.1.8-10.el6cf.src.rpm
 * katello-configure-1.1.9-10.el6cf.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-1.1.1-2.el6cf.src.rpm
Comment 5 Garik Khachikyan 2012-10-31 10:40:23 EDT
# COMMENT

doing click on "Reset Password" (without entering any info in fields) brings to the red alert:
---
Couldn't find User with username = , email =

we seems missing a check on text input(s) emptiness
Comment 6 Og Maciel 2012-10-31 10:43:35 EDT
Also, choosing "Forgot username", entering a valid email and clicking "Send Login" doesn't seem to actually send an email.
Comment 7 Og Maciel 2012-10-31 10:44:48 EDT
Created attachment 636163 [details]
empty radio button in dialog

There's a radio button with no text displayed in the dialog.
Comment 8 James Laska 2012-10-31 10:45:14 EDT
(In reply to comment #5)
> # COMMENT
> 
> doing click on "Reset Password" (without entering any info in fields) brings
> to the red alert:
> ---
> Couldn't find User with username = , email =
> 
> we seems missing a check on text input(s) emptiness

Confirmed, I'm seeing that also.  The message seems like it could be presented better.  Something like, "No matching user found".

I could be wrong, but I think that's slightly different from the reported issue.  We should have a bug to track improving the reading of that notification.  I'm not sure whether the issue in comment#0 and comment#5 should be tracked by the same bug. 

Any input from devel?
Comment 11 Jason E. Rist 2012-12-17 17:59:53 EST
Og - I think that we should probably file a separate bug if you're not getting an email.  (I think there might already be a closed bug and documentation on that issue alone.)
Comment 13 Mike McCune 2014-03-18 13:37:34 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.