Bug 865909 - rhc --version doesn't show the version
rhc --version doesn't show the version
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 15:27 EDT by Luke Meyer
Modified: 2015-05-14 22:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.99.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2012-10-12 15:27:19 EDT
Description of problem:
"rhc -v" doesn't work.

Version-Release number of selected component (if applicable):
rhc-0.99.5-1.git.204.6603d60.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Install rhc-0.99.5-1.git.204.6603d60.el6.noarch
2. run "rhc -v"
  
Actual results:
"
Usage: rhc (<resource> | --help) [<action>] [<args>]
Command line interface for OpenShift.

List of Commands and Resources
"
...

Expected results:
rhc 0.99.5
Comment 1 John (J5) Palmieri 2012-10-15 10:48:34 EDT
taking.  rhc <command> --version works but rhc --version doesn't.  Looks like we might be short circuiting if no command is given
Comment 2 Peter Ruan 2012-10-16 18:23:45 EDT
verified with 0.99.7
[pruan@homer-linux <MASTER> bin]# rhc -v
rhc 0.99.7

Note You need to log in before you can comment on or make changes to this bug.