Bug 865941 - after firefox update: undefined symbol: PR_SetCurrentThreadName
after firefox update: undefined symbol: PR_SetCurrentThreadName
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 17:04 EDT by Josh Trutwin
Modified: 2012-11-04 08:59 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 02:16:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Trutwin 2012-10-12 17:04:46 EDT
Description of problem:

Hi I recently upgraded one of my Fedora 17 installations firefox package from version 14.0.0-1 to 16.0.0-1 and now when running firefox I get this error:

$ firefox
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName

Version-Release number of selected component (if applicable):

$ rpm -q firefox
firefox-16.0.1-1.fc17.x86_64
$ rpm -q xulrunner
xulrunner-16.0.1-1.fc17.x86_64


How reproducible:


Steps to Reproduce:
1.  Just need to type "firefox" on terminal - nothing opens, error is diaplayed

  
Actual results:

$ firefox
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName

Expected results:

Firefox opens.  :)

Additional info:

Previous versions:

$ rpm -q firefox
firefox-14.0.1-1.fc17.x86_64
$ rpm -q xulrunner
xulrunner-14.0.1-3.fc17.x86_64


$ uname -a
Linux lin18.cs.csbsju.edu 3.5.2-1.fc17.x86_64 #1 SMP Wed Aug 15 16:09:27 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


Let me know what else I can provide.

Josh
Comment 1 Josh Trutwin 2012-10-12 17:08:05 EDT
My bad - replace this: "14.0.0-1 to 16.0.0-1" with "14.0.1-1 to 16.0.1-1" above.
Comment 2 Tim W. 2012-10-12 23:48:23 EDT
I observe the same behavior on my installation.  FC17, kernel 3.5.3-1.fc17.x86_64, firefox and xulrunner are at 16.0.1-1.fc17.x86_64
Comment 3 Kathy 2012-10-13 10:53:21 EDT
This also applies to FC16 64bit :

$ rpm -q firefox
firefox-16.0.1-1.fc16.x86_64
$ rpm -q xulrunner
xulrunner-16.0.1-1.fc16.x86_64

I also tried to roll back the changes, but the older version is reliant on files that no longer exists (wrong version name) not really interested in fixing to use the old. Would rather test a newer version and get back to Firefox ;) 

Kat.
Comment 4 Kevin Fenzi 2012-10-14 02:02:39 EDT
If you do a 'yum update nspr' does it start working?
Comment 5 Kathy 2012-10-14 02:14:33 EDT
(In reply to comment #4)
> If you do a 'yum update nspr' does it start working?

Hi Kevin,

This fixes it :)

Regards,

Kat.
Comment 6 Michael 2012-10-14 09:58:02 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > If you do a 'yum update nspr' does it start working?
> 
> Hi Kevin,
> 
> This fixes it :)
> 
> Regards,
> 
> Kat.

Thanks Kevin et al.  Same problem on fc16.  Resolved.

Michael
Comment 7 Michael Ben-Gershon 2012-10-14 10:05:50 EDT
Well, I am sorry to say that I tried this and it did not help. I have checked the versions and this is what I get:

Linux-mybg (15:54) > rpm -qa firefox xulrunner nspr
nspr-4.9.2-1.fc16.x86_64
nspr-4.9.2-1.fc16.i686
xulrunner-16.0.1-1.fc16.x86_64
firefox-16.0.1-1.fc16.x86_64
Comment 8 Kevin Fenzi 2012-10-15 12:18:08 EDT
(In reply to comment #7)
> Well, I am sorry to say that I tried this and it did not help. I have
> checked the versions and this is what I get:
> 
> Linux-mybg (15:54) > rpm -qa firefox xulrunner nspr
> nspr-4.9.2-1.fc16.x86_64
> nspr-4.9.2-1.fc16.i686
> xulrunner-16.0.1-1.fc16.x86_64
> firefox-16.0.1-1.fc16.x86_64

Are you sure you completely stopped all firefox processes and restarted? 

You see the same error as above running from a terminal? Or something else?
Comment 9 Michael Ben-Gershon 2012-10-15 12:45:36 EDT
(In reply to comment #8)

> Are you sure you completely stopped all firefox processes and restarted? 
> 
> You see the same error as above running from a terminal? Or something else?

I am absolutely sure that everything was shut down. I even tried closing down the X server and restarting.

This error is seen from a terminal.

By the way, there is no error on my machine when running the 64 bit firefox build from the mozilla website, only the fc16 version from yum.
Comment 10 Kevin Fenzi 2012-10-16 11:57:42 EDT
ok, how about output of: 

rpm -V nspr
Comment 11 Michael Ben-Gershon 2012-10-16 12:13:48 EDT
Linux-root (18:12) /home/mybg # rpm -v -V nspr
.........    /lib64/libnspr4.so
.........    /lib64/libplc4.so
.........    /lib64/libplds4.so
.........    /lib/libnspr4.so
.........    /lib/libplc4.so
.........    /lib/libplds4.so
Comment 12 Kevin Fenzi 2012-10-16 15:02:24 EDT
Not sure what could be the issue then. I'll let firefox maintainers chime in...
Comment 13 taj 2012-10-18 00:19:24 EDT
I found 'yum update nspr' fixed a couple fc16 systems laying around.  Adjusting the rpm dependencies would certainly help many people.
Comment 14 Martin Stransky 2012-10-18 02:16:18 EDT
There's an update for that:

https://admin.fedoraproject.org/updates/FEDORA-2012-16259/xulrunner-16.0.1-2.fc17
Comment 15 Michael Ben-Gershon 2012-10-18 04:38:27 EDT
(In reply to comment #13)
> I found 'yum update nspr' fixed a couple fc16 systems laying around. 
> Adjusting the rpm dependencies would certainly help many people.

Made no difference for me though!
Comment 16 Martin Stransky 2012-10-18 04:45:51 EDT
Please install packages from the update - https://admin.fedoraproject.org/updates/FEDORA-2012-16259/xulrunner-16.0.1-2.fc17 (or the f16/18 ones).
Comment 17 cje 2012-10-22 06:28:44 EDT
sorry to comment after closing.  i hit this problem because one of my computers has 'automatically install security updates' enabled.  computers in that situation won't (automatically) pick up the updated xulrunner because it's not a security update.

is there any chance we can have another xulrunner update which is flagged as a security update?  i'm guessing that would break a fedora policy somewhere?
Comment 18 Anonymous Coward 2012-10-26 15:31:09 EDT
In case it helps/matters to the packagers a little more information.  This problem popped up today.  In solving it I looked at /var/log/yum.log and found that the update did update xulrunner and firefox, but not nspr.  I can't tell if I have security updates on or not (in response to comment #17) but it did run automatically without my running yum.  At least I think so: I ran yum earlier that day and later, but not at the time the log shows.

This was the installation from /var/log/yum.log:

  Oct 25 12:19:52 Updated: 12:dhcp-libs-4.2.4-4.P2.fc16.i686
  Oct 25 12:19:52 Updated: 32:bind-license-9.8.4-2.fc16.noarch
  Oct 25 12:19:52 Updated: 32:bind-libs-lite-9.8.4-2.fc16.i686
  Oct 25 12:19:53 Updated: 12:dhcp-common-4.2.4-4.P2.fc16.i686
  Oct 25 12:19:54 Updated: 32:bind-libs-9.8.4-2.fc16.i686
  Oct 25 12:19:58 Updated: xulrunner-16.0.1-1.fc16.i686
  Oct 25 12:20:12 Updated: 1:java-1.6.0-openjdk-1.6.0.0-68.1.11.5.fc16.i686
  Oct 25 12:20:13 Updated: 12:dhclient-4.2.4-4.P2.fc16.i686
  Oct 25 12:20:15 Updated: dracut-018-60.git20120927.fc16.noarch
  Oct 25 12:20:34 Updated: 1:java-1.7.0-openjdk-1.7.0.9-2.3.3.fc16.i686
  Oct 25 12:20:40 Updated: firefox-16.0.1-1.fc16.i686
  Oct 25 12:20:41 Updated: 32:bind-utils-9.8.4-2.fc16.i686
  Oct 25 12:20:42 Updated: openjpeg-libs-1.4-14.fc16.i686
Comment 19 Michael Ben-Gershon 2012-10-27 12:49:58 EDT
The problem is that I also updated nspr and it did not help. I tried uninstalling firefox xulrunner and nspr in order to reinstall them from afresh. However, nspr has vast things which depend on it so I could not uninstall it sensibly.
Comment 20 Stuart D Gathman 2012-10-27 15:59:25 EDT
(In reply to comment #19)
> The problem is that I also updated nspr and it did not help. I tried
> uninstalling firefox xulrunner and nspr in order to reinstall them from
> afresh. However, nspr has vast things which depend on it so I could not
> uninstall it sensibly.

yum reinstall nspr
Comment 21 Michael Ben-Gershon 2012-10-28 03:36:50 EDT
(In reply to comment #20)

> yum reinstall nspr

Tried that. no help.
Comment 22 Martin Stransky 2012-10-29 03:27:00 EDT
Please test new updates - https://admin.fedoraproject.org/updates/FEDORA-2012-17028/firefox-16.0.2-1.fc17,xulrunner-16.0.2-1.fc17

If it does not help please post ld.so log:

$ export LD_DEBUG=all
$ export LD_DEBUG_OUTPUT=~/log.txt
$ firefox

there will be log.txt.XXXXX files in your home (XXXXX is a pid of loged processes) , please attach them.
Comment 23 Michael Ben-Gershon 2012-11-04 08:59:02 EST
I have installed the updates, but they do not help. However, I have found a workaround, which those who understand these things a little better than me could probably use to find what is wrong!

If I comment out the following lines in run-mozilla.sh it works fine!

lines 277-280:

#if moz_should_set_ld_library_path
#then
#	LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH:+":$LD_LIBRARY_PATH"}
#fi

Note You need to log in before you can comment on or make changes to this bug.