Bug 865952 - Calender items change 'calendar' on copy and paste
Calender items change 'calendar' on copy and paste
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 17:38 EDT by Mark van Rossum
Modified: 2012-10-15 12:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 12:21:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 473250 None None None 2012-10-15 12:21:27 EDT

  None (edit)
Description Mark van Rossum 2012-10-12 17:38:53 EDT
Description of problem:

I have multiple calendars defined in evolution, say work and private (each with their own color)
When I copy and paste calendar items, items from the 'work' calendar become 'private' (and change color).
THe calendar selection panel on the left determines the calendar of the pasted item.

This could be the desired behaviour, but I find that unlikely.


Version-Release number of selected component (if applicable):
evolution-3.6.0-1.fc18.x86_64 (since F18 alpha)

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Milan Crha 2012-10-15 12:21:11 EDT
Thanks for a bug report. You are right that this is intended behaviour. I did "WontFix" this almost a year ago in the upstream bugzilla [1]. The worse might be to add an option for it, or, in this particular case, know that the event came from evolution itself, thus it's able to re-use the calendar. Let's discuss it in the upstream bugzilla (maybe there are left opened similar bugs).

[1] https://bugzilla.gnome.org/show_bug.cgi?id=473250

Note You need to log in before you can comment on or make changes to this bug.