Bug 865954 - subscription-manager-firstboot hangs on Registration spinner when an invalid system name is entered.
subscription-manager-firstboot hangs on Registration spinner when an invalid ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: 6.4
Assigned To: John Sefler
IDM QE LIST
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-10-12 17:47 EDT by John Sefler
Modified: 2013-01-09 12:45 EST (History)
3 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.4-1
Doc Type: Bug Fix
Doc Text:
Cause: Incorrect error handling of invalid system names. Consequence: The user would be left in unusable state during firstboot. Fix: Correctly handle invalid system names. Result: Firstboot works correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:45:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
After entering a System Name: "Foo Bar", firstboot hangs on Registering spinner. (109.83 KB, image/png)
2012-10-12 17:47 EDT, John Sefler
no flags Details
clicking OK on an invalid system name error dialog now returns to the credentials panel (132.56 KB, image/png)
2012-10-17 10:18 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-10-12 17:47:13 EDT
Created attachment 626316 [details]
After entering a System Name: "Foo Bar", firstboot hangs on Registering spinner.

Description of problem:
During the firstboot workflow, if you supply an invalid "System Name:" value (e.g "Foo Bar" on the Subscription Registration credentials panel, then you will get an error dialog as shown in the attached screenshot.  Pressing "OK" on the error dialog leaves you hanging on the Registering spinner.  Since the Back/Forward buttons are disabled while the spinner is busy, the user is stuck.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.0.22-1.el5

How reproducible:
always

Steps to Reproduce:
described above
Comment 1 John Sefler 2012-10-12 17:57:07 EDT
Additional Info:
  List of characters that can not be used in the System Name:
    https://bugzilla.redhat.com/show_bug.cgi?id=677405#c1
    plus white space
    and greater than 250 characters
Comment 2 John Sefler 2012-10-12 17:59:21 EDT
    and cannot begin with a # character
Comment 3 RHEL Product and Program Management 2012-10-12 18:08:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Adrian Likins 2012-10-16 09:44:23 EDT
Fixed in master with:


commit e99938f821a9bc4ac78eeba670854e8e487b3de5
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Oct 11 13:53:14 2012 -0400

    865954: Return to creds screen if consumer name is invalid
    
    When we register a consumer, if the consumer name is in
    an invalid format, we were raising an error, but handling
    it poorly. Now we send the user back to the credentials
    screen (where the consumer name field is).


merge to 5.9 pending
Comment 5 Adrian Likins 2012-10-16 12:04:30 EDT
In 5.9


commit cbe824bd460e8811f89f0ca89e15e49df2788463
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Oct 11 13:53:14 2012 -0400

    865954: Return to creds screen if consumer name is invalid
    
    When we register a consumer, if the consumer name is in
    an invalid format, we were raising an error, but handling
    it poorly. Now we send the user back to the credentials
    screen (where the consumer name field is).

(should land in 1.0.23)
Comment 8 John Sefler 2012-10-17 10:18:36 EDT
Created attachment 628834 [details]
clicking OK on an invalid system name error dialog now returns to the credentials panel

Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.0.23-1.el5
Comment 10 Bryan Kearney 2013-01-09 12:45:57 EST
Batch change of verified bugs which must have missed making the errata.

Note You need to log in before you can comment on or make changes to this bug.