Bug 865966 - brcmsmac not auto-loaded
brcmsmac not auto-loaded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Greene
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 19:03 EDT by Milan Kerslager
Modified: 2012-11-21 16:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 16:24:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci - n -vvvv (2.48 KB, text/plain)
2012-10-12 19:11 EDT, Milan Kerslager
no flags Details
diff pre and post: modprobe brcmsmac (1003 bytes, text/plain)
2012-10-19 02:56 EDT, Milan Kerslager
no flags Details
diff of dmesg (pre and post modprobe brcmsmac) (2.35 KB, text/plain)
2012-10-19 02:57 EDT, Milan Kerslager
no flags Details
whole dmesg output (post modprobe brcmsmac) (74.49 KB, text/plain)
2012-10-19 02:59 EDT, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2012-10-12 19:03:17 EDT
In the time of kernel 3.4.x, I had to use binary blob.
When 3.5 was near to launch, there was opensource brcmsmac. I tested this driver many times.
In the time of launch 3.5.0, the driver was perfect for me. I'm using open networks, but mostly encrypted ones (eduroam with 802.1X, WPA2/PSK at home) with no problem at all.
But then around 3.5.1, the tried sopped to auto-load. I have to load it manually. Even that, the driver works for me like charm. I have no problem with it even I see here some bug reports.

So I'm asking to put this PCI-ID to current kernel to utilize this driver without manual intervention.
Comment 1 Milan Kerslager 2012-10-12 19:11:33 EDT
Created attachment 626338 [details]
lspci - n -vvvv

My wireless card in HP ProBook 6555b.
Comment 2 Josh Boyer 2012-10-15 05:46:23 EDT
Can you attach the output of 'dmesg' and 'lsmod' after you boot and before you load the module manually?  There was an issue a while ago where the phy module brcmsmac needs wasn't being included in the initramfs and so the module wouldn't load properly.

The output of dmesg after you load the module would also be useful.
Comment 3 Milan Kerslager 2012-10-19 02:56:29 EDT
Created attachment 629816 [details]
diff pre and post: modprobe brcmsmac
Comment 4 Milan Kerslager 2012-10-19 02:57:45 EDT
Created attachment 629817 [details]
diff of dmesg (pre and post modprobe brcmsmac)
Comment 5 Milan Kerslager 2012-10-19 02:59:20 EDT
Created attachment 629828 [details]
whole dmesg output (post modprobe brcmsmac)
Comment 6 Milan Kerslager 2012-11-20 14:33:22 EST
The is no change. The module is still not beeing loaded.
Comment 7 Milan Kerslager 2012-11-21 09:25:57 EST
My actual kernel is latest from updates (3.6.6-1.fc17.x86_64), module does not load.
Comment 8 Arend van Spriel 2012-11-21 12:52:51 EST
Could it be you have bcma and/or brcmsmac blacklisted. The broadcom-wl driver will try to do that during install/upgrade. I guess you removed that driver when switching to brcmsmac, but the blacklist files may still be there. Just trying to eliminate the obvious problems here.
Comment 9 Milan Kerslager 2012-11-21 16:24:46 EST
Yes. Sorry and thank you a lot.

Note You need to log in before you can comment on or make changes to this bug.