Bug 865967 - RHEL 5.9 BUG: Logging out of desktop produces traceback in /var/log/Xorg.0.log.old
RHEL 5.9 BUG: Logging out of desktop produces traceback in /var/log/Xorg.0.l...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.9
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 19:08 EDT by Jeff Burrell
Modified: 2013-01-08 02:40 EST (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.1.1-48.100.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:40:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old file (64.75 KB, application/octet-stream)
2012-10-12 19:08 EDT, Jeff Burrell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0083 normal SHIPPED_LIVE xorg-x11-server bug fix update 2013-01-07 10:26:52 EST

  None (edit)
Description Jeff Burrell 2012-10-12 19:08:58 EDT
Created attachment 626336 [details]
Xorg.0.log.old file

Description of problem:

We've found that some errors are reported when you log out of the RHEL 5.9 desktop. This occurs on any system with an nVidia or AMD graphics card installed, with the in-box open source drivers or with the third party closed source driver installed. We do see that it happens when the card-2-monitor connection is DP.  This error does not seem to happen when you're connected to a DVI connection.

The following backtrace can be found in the Xorg.log.old file:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80c3511]
1: [0xe2e420]
2: /usr/bin/Xorg [0x81186b4]
3: /usr/bin/Xorg [0x8129d94]
4: /usr/lib/xorg/modules/libramdac.so [0x98e837]
5: /usr/bin/Xorg [0x81229f5]
6: /usr/bin/Xorg [0x815f0cd]
7: /usr/bin/Xorg(FreeCursor+0x6a) [0x807ee3a]
8: /usr/bin/Xorg(main+0x4d7) [0x80709a7]
9: /lib/libc.so.6(__libc_start_main+0xdc) [0x14eebc]
10: /usr/bin/Xorg(FontFileCompleteXLFD+0x205) [0x806fc51]

Fatal server error:
Caught signal 11. Server abortin


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Install RHEL 5.9/SS1/64
2. Reboot and answer firstboot questions
3. Login and proceed to desktop
4. Use the menu option to log out

  
Actual results:
Upon logging back into the desktop, you will see a /var/log/Xorg.0.log.old file which contains the backtrace shown above


Expected results:
No errors, no backtrace


Additional info:
Comment 1 Adam Jackson 2012-11-02 16:54:46 EDT
Raising for 5.9, this is probably due to some memory leak fixes applied in 5.9.
Comment 2 Adam Jackson 2012-11-05 11:44:37 EST
Devel ack for fixing this, it's clearly a regression introduced by the memory leak fixes already applied.
Comment 3 Adam Jackson 2012-11-07 16:52:30 EST
Probably fixed by this build:

https://people.redhat.com/~ajackson/865967/

Please test.
Comment 7 Jeff Burrell 2012-11-12 17:33:39 EST
As far as I can tell, the trace back issue has been fixed by these changes.

Would this have been expected to be in snapshot 5?  I'm not seeing it there...
Comment 8 Michael Boisvert 2012-11-13 15:04:33 EST
I reproduced the backtrace on xorg-x11-server-1.1.1-48.98.el5. Upon installing xorg-x11-server-1.1.1-48.100.el5, the backtrace did not reappear. 

Verified.
Comment 10 errata-xmlrpc 2013-01-08 02:40:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0083.html

Note You need to log in before you can comment on or make changes to this bug.